Associate nsx files

Just got my new version 8.2 and checking it out. The first thing I noticed is that nsx files are not associated with the application development tool. Double clicking the file doesn’t work anymore. After right clicking a nsx file and selecting properties I tried to change the “open with” to Application development tool but it defaults back to “unknown application” resulting in my having to make an extra step each time I double click a nsx file. I never had to do this with my previous version (6). I also tried “appstudio.exe” as the file to open the nsx file without results. Is there a workaround? I use windows 7. My laptop with win 10 does not have that issue. Please see what your nsx files are associated with to open. Thank you very much.

Microsoft has dropped support for Windows 7, as have we. You may still be able to open the older projects by going to the File menu and using “Open Older Project”. It allows you to select .nsx files.

If you do a Save As… of your project into a new folder, it will convert everything to AppStudio 8 format. The main project file will end in .project, and the new folder will end in .appstudio.

For more about the new project format (introduce in AppStudio 7):