Creating an App Menu

I resurrected a older app that is designed for an ipad and started getting errors on a menu the comes up on the first form. In reading I found the old menu control has been deprecated and I had to find some replacement. Not sure where I should go as I didn’t see any mention of a substitute I selected the JqwList.

Setting the Changeform properties I tried to run it and am getting either style errors or sql errors.

Form1: Uncaught TypeError: Cannot read property ‘style’ of null

Forms 2 & 3:
The sql errors: Uncaught TypeError: Cannot read property ‘supplant’ of undefined. If I click on the link below the message I get:
NSB.MsgBox(‘SQLite error: {errmsg} (Code {errcode}) {sql}’).supplant(
“errmsg”: err.message,
“errcode”: err.code,
“sql”: lastSQL
Of course the displayed message only show the placeholders and no actual error message.

These were working Sql procedures and now all fails. So my first question is the JqwList correct for use as a menu? I don’t know where to go regarding the new SQL errors.

If you would point me in the right direction or get me some docs I can refer to. Frustrated.


The message on Forms 2 and 3 is misleading. The error message is getting trapped and the error handling code itself is throwing an error. Oops!

Let’s tackle the Form1 error first - maybe it will help with the other two.

What’s happening in the line which is causing the Uncaught TypeError: Cannot read property ‘style’ of null message?

I hope this works but I have uploaded images of the form and errors.


Let me know if any of this got through. Easier than typing it all out.


Ah! Looks like you’re using a jQuery Mobile List, not JqwList.

The most likely reason for the error is that a form id in the ChangeForm property is incorrect. Can you check those?

You are correct. My wild typing added an “s” to the form ID in that property.

Now I have to go through and see what the SQL “supplant” issues are. This code had worked but that was back in v6. I can usually figure sql stuff out but the “supplant” is side tracking me.

Thanks, Bob

The supplant issue is a bit of a red herring. We’ve got code which is supposed to handle errors in SQLite calls, but there’s a bug in it. (It’s fixed in the next build.)

Can you figure out what SQLite command you’re issuing when you get the error?

I’ll see if I can trap it.