Error message at Chrome (auf Deutsch)

Korrektur zu 4.: Es dürfen nicht Höhe und Breite gleichzeitig mit 100% angegeben werden. Bei einem Bild im breiten Format setze ich width auf 100% und height auf auto, sonst gibt es Streckung/Verzerrung nach oben. Also nur das Maß, das vollständig erscheinen soll, auf 100%.

Habe diverse Korrekturen vorgenommen, wie von Dir vorgeschlagen.

Manchmal verstehe ich die Welt nicht mehr, denn damit der Bildschirm im Querformat Scrollen kann, muss “scrolling” auf “Aus” eingestellt sein!

Mit dem Start der 2 Apps für die CH-Gemeinden komme ich nicht weiter, weiss auch nicht mehr was machen.

Hast Du noch eine Ide?

image001.jpg

Jedenfalls https://07-habis-ch-gemeinde-1.volt.live/ , mit Datum 9.10., sieht bei mir gut aus. Startet sofort. Bilder sind nicht mehr verzerrt, wenn man die Bildschirmgröße ändert.
Wahrscheinlich ist es ohnehin schöner, die App, so wie sie gestaltet ist, nur in Portrait zu betreiben. Dann könnte man einrichten, dass sie nur in Portrait läuft, also nicht gedreht werden kann. Ich habe nur quer gedreht, weil ich sehen wollte, ob die Bilder beim Drehen des Smartphone und damit Verbreiterung des Bildschirms verzerrt werden. Weiß aber momentan nicht, wo man das in AppStudio einstellt (ich arbeite auch mit anderen Programmen als AppStudio und habe nicht sofort parat, was wo wie geht).
Meine Idee wäre, dass du mir von den 2 Apps, die du als problematisch ansiehst, jeweils die Projekt-Verzeichnisse als zip file schickst. Dann könnte ich vielleicht sehen, was bei dir anders eingestellt ist, als bei meinen mich zufrieden stellenden Apps.

Das wäre natürlich super, wenn Du dafür Zeit hättest.

Ich habe aber ein Problem: die .zip Datei ist etwa 110MB gross und kann so nicht ans E-Mail angehängt werden.

Wie muss ich das machen?

Zum Voraus besten Dank

image001.jpg

Meine frühere, direkte, Antwort aus Outlook ist wieder abgelehnt worden. Hier also noch einmal:

Kein Problem (Zeit etc.).

Ich mache so etwas mit Microsoft OneDrive oder Dropbox und – je nach Konstellation – mit Teamviewer.
Schlage vor, wenn du nicht OneDrive eingerichtet hast, ein Konto bei Dropbox anzulegen.

Werde gerade gerufen. Bis später

Habe noch etwas entdeckt, das einfach aussieht. Im Browser in Adresszeile eingeben:

also send.firefox.com
Geht bis 1 GB ohne Anmeldung.
Meine Adresse ist: bsommer@bsommer.de

Ok, Dropbox habe ich, weiss aber nicht wie die Dateien versenden!

Kannst Du mir eine Anleitung geben.

image001.jpg

Hier der Link, hoffe alles richtig gemacht zu haben!

~WRD000.jpg

image001.jpg

image004.jpg

Wunderbar. Hat alles gepasst. Bin gerade beim Entpacken der ZIPs.

Die App startet in Chrome und funktioniert prima.
Jetzt erst verstehe ich, was du mit den ewig langen Wartezeiten gemeint hast. Diese habe ich auch, wenn ich in AppStudio zwischen Design Screen und Code usw. wechsele, also Wartezeiten nur in der Entwurfsphase.
Dazu ist mir aufgefallen, dass in der manifest Datei (für PWA) zwei Icons im Pfad nsb/images/ zu finden sein sollen, ich aber keinen Ordner nsb sehe. Diese Frage kommt mir altbekannt vor, weiß aber nicht mehr, was George dazu gesagt hat. Jedenfalls würde ich probieren, auch die Icons, die bisher bei nsb/images/ sein sollen, als eigene Icons im Ordner includes anzulegen und darauf zu verweisen.
Vielleicht kommt die lange Zeit in AppStudio daher, dass diese nsb icons gesucht und nicht gefunden werden. Das würde auch erklären, dass du auch einmal geschrieben hast, glaube ich, Icons würden nicht dargestellt.
Ich schaue mich weiter um …

Zum Start von AppStudio über die .project Datei ist mir noch eingefallen: Acronis True Image hat das erst einmal blockiert, da es AppStudio für malware gehalten hat. Da habe ich es auf die Whitelist setzen können und dann erst ist AppStudio gestartet. Vor einigen Wochen hat Kaspersky sowohl ein Update zu AppStudio einfach gleich gelöscht, als vermeintlichen Trojaner, als auch die mit AppStudio erstellten Apps, wenn ich sie auf dem PC installiert (PWA und PhoneGap) habe. Habe ich an K. gemeldet und sie haben das korrigiert. Lange Startzeit: Jetzt wäre es auch denkbar, dass deine Virensoftware bei jedem Vorgang um AppStudio langwierig prüft, ob irgendwo malware drin steckt.

Bei den Eigenschaften zu PWA könntest du vielleicht auch einen Titel für den Homescreen eingeben, denn die manifest Datei möchte diesen übernehmen. Wenn man den Titel passend angibt, erkennt man dann auch gleich am Namen, dass es eine installierte PWA ist.

Ich schaue mich weiter um. Macht mehr Spaß, als das überfällige Staubsaugen :slight_smile:

Die manifest-Datei wird von NSB-App erzeugt und ist bei allen Apps in dieser Form vorhanden (hat etwas mit dem App-Icon (Grösse) zu tun. Ich verwende 192 x 192.

Habe versucht die anderen beiden Einträge zu lösen. Ergibt aber keine Verbesserung!

image001.jpg

Ich habe mich ungeschickt ausgedrückt. Es scheint nicht nsb zu fehlen, sondern nsb/images, also ein Ordner images. Den sehe ich im Chrome Debugger nicht.
Wenn ich mich recht erinnere, sollten im Ordner extrafiles auch die Ordner aufgeführt werden, in welchen man z.B. eigene Bilder untergebracht hat, z.B. bei dir “includes”.
“Files to include with your project. These files should be in your project’s folder. If you include the name of a folder, the folder and all of its files will be included.”
Weshalb die Bilder trotzdem kommen, ist mir momentan nicht klar.

Du verwendest jqmobile controls. In einem Blog steht:
We’re pleased to announce that 7.4.1 has been released.

The biggest change is that the Samples now use Bootstrap 4 controls instead of jQuery Mobile. As mentioned before, it’s been 5 years since jQuery Mobile has been updated. If you’re still using it in your projects, please consider updating.

Mit der manifest-Datei kenne ich mich nicht aus (habe noch nie etwas damit gemacht!)

Vielleicht kann man dort auch den “Start-Bildschirm” der Apps verändern!

Jetzt ist er immer schwarz und in der Mitte das NSB-App Icon (wäre sicher schöner mit etwas anderem).

Vorgehen wenn das Programm fertig ist:

  • F5 (zur Überprüfung auf Fehler

  • “Bei Volt bereitstellen”

  • Bei Volt Namen vergeben und speichern.

  • URL im Chrome eingeben und öffnen

  • Das wars (etwas anderes kenne ich nicht!)

image001.jpg

image002.jpg

Ein Beispiel aus einem manifest bei mir:

{{
  "short_name": "{title}",
  "name": "{title}",
  "display": "standalone",
  "start_url": "index.html",
  "background_color": "black",
  "theme_color": "black",
  "icons": [
    {{
      "src": "ParEurIcon72x72.png",
      "sizes": "72x72"
    }},
    {{
      "src": "{icon}",
      "sizes": "192x192"
    }},
    {{
      "src": "ParEurIcon512x512.png",
      "sizes": "512x512"
    }},
    {{
      "src": "Square310x310Logo.scale-100.png",
      "sizes": "310x310"      
    }},
    {{
      "src": "Wide310x150Logo.scale-100.png",
      "sizes": "310x150"      
    }},
    {{
      "src": "Square310x310Logo.scale-400.png",
      "sizes": "310x310"      
    }},
    {{
      "src": "Wide310x150Logo.scale-400.png",
      "sizes": "310x150"      
    }}
  ]
}}

Bei title wird eingesetzt, was in der Zeile über manifest als Titel eingetragen ist.
Bei icon in geschweiften Klammern wird eingesetzt, was in den Properties als icon angegeben ist.

Ich habe nur bei den übrigen Icons etwas geändert, weil ich ja meine eigenen Icons statt der AppStudio Symbole verwenden wollte. Das klappt auch so. Mit den Ergänzungen mit den 4. bis 7. icons bin ich einfach einmal einer Empfehlung gefolgt, kann aber nicht erkennen, ob ich damit irgendwo etwas bewirke. Kannst du also weglassen. Nur 3 Icons, wie vorgegeben, müssten genügen. Diese png Icons habe ich im Hauptverzeichnis abgelegt und deshalb auch keinen Pfad eintragen brauchen.
Dass es mit den Bildern funktioniert, obwohl includes nicht in extraFiles eingetragen ist, erkläre ich mir jetzt damit, dass du sämtliche Bilder im Project-Explorer hast und dort bei jedem Bild der Pfad eingetragen ist. Das ist aber meine freie Phantasie, denn ich habe das noch nicht so gesehen, dass alle Bilder direkt im Project-Explorer aufgezählt sind. Ich habe so etwas in einer Datei, in welcher alle Klänge von allen Klaviertasten vorgespielt werden können. Da werden oder wurden beim Programmstart alle 2 x 88+ Tondateien in den Explorer geladen. Das hat bei jedem Start des Projekts ärgerlich lang gedauert.

Das Vorgehen erscheint mir OK so, außer dass ich ja auf meinem Server bsommer.de bereitstelle und dort auf den Link zur App klicke. Willst du sagen, dass sich auf die URL hin die App in Chrome nicht öffnet?

Welche Einstellungen zu Volt du bei Werkzeuge/Einstellungen vorgenommen hast, kann ich nicht sehen, nur meine eigenen. Vorsorglich hier der Link zu einer Anleitung https://wiki.appstudio.dev/Volt_for_appstudio

Doch die App öffnet sich im Chrome richtig!

image001.jpg

Wenn du meinst, dass die 2 Gemeinde-Apps nicht richtig funktionieren, sie es aber unter Chrome bei dir und mir sehr gut tun, habe ich noch nicht verstanden, welcher Fehler gesucht werden oder welches Problem beseitigt werden soll.

manifest: Ich habe es einmal so verstanden, dass alle drei vorgegebenen Icons benötigt werden, da die verschiedenen Größen an verschieden Stellen benötigt werden. Ich glaube nicht, dass es ausreicht, nur ein 192 x 192 png anzugeben.
Wenn meine grobe Vermutung passt, dass die Pfade zu den nsb icons nicht korrekt sind, dann könnte ich vorschlagen, alle drei Icons direkt in das Hauptverzeichnis der App zu kopieren und in manifest die Pfadangaben zu löschen, siehe mein manifest oben. Vielleicht wird bei dir wegen der Pfadprobleme nicht das richtige Icon gefunden.

Re: Doch die App öffnet sich in Chrome richtig

Hast du da ein Bild eingefügt? Ich kann es nicht sehen