How to load audio file into app?

I’ve created an audio file, .wav
I put it on my desktop.
I open NSB to the app…
I drag the audio file from the desktop to the “Project Explorer” and drop it.
Nothing happens.
I drop it on the icon for the Form where I want the audio file.
Nothing happens.
I look through all the Forms in the app.
No .wav file.
What am I doing wrong?

Windows10… NSB AppStudio

BTW, I did the same thing in the ‘sample’ app for playSound and it worked perfectly, i.e., the audio file appeared in the “Project Explorer” for the sample app.

Don’t drop it onto a form - drop it in the empty area under all the forms.

Also, the latest version is 6.3.1 - though it probably won’t make a difference in this case.

Got it… Thanks… I’ll let you know…

Sorry, still does not work…
Can’t load the .wav file… but here’s the full program…
SkillMeNowMeetings.nsx (503.4 KB)

Note that there will be a button in the “Navigation” Collapsible which will trigger the audio…

Have you checked in the Chrome Debugger for error messages?

Chrome Debugger shows no messages.

Just loaded and same issue… drag and drop the .wav file to the bottom of the Project Explorer panel and nothing happens… the .wav file is not moved, in spite of the arrow tag that says “move”…

It was that I installed, NOT

Why do you want to move it?

??? I want to move it from the desktop to the app.
(When I drag the audio file over the Project Explorer panel, ‘attached’ to the file is a tag consisting of an arrow and the flag containing the word ‘move’… that’s the ‘move’ I’m referring to… )

In your project I can drag an wav file to the empty area under all the forms. It inserts the wav as in the example project

Hmmm… could it be the .wav file I’m using??? Is there a size limit of the .wav file when used in NSB?.. One is 10MB and the other is 12.7MB… I’ve attached the latter.

I just tried it again (with the attached .wav file)… When I click on the .wav file on the desktop and drag to NSB Properties Pane, below all of the other entries (in the empty space) a small blue circle with a dot in the middle appears, and attached to the file icon is a rectangular ‘flag’ containing an arrow and the word “move”. When I release it, the circle and ‘flag’ and icon all disappear and nothing happens… no file is added to the Pane.

Nothing was attached - I suspect it’s too big an attachment. As the database admin for the discussion board, I’m actually OK with that. :slight_smile:

Have you tried a small .wav file? Does it work?

Have a look at the AudioVideo sample. It streams the sound instead, so there’s no need to include the file with the app.

I just tested with a .wav file that is 850KB… about 5 seconds of recording… got the same results as above. :cry:

Regarding using AudioVideo… I assume I would need a server to hold the AV file… I have neither the technical capability nor the finances to set up/“rent” a server. Even if the server were to be Volt, the user would have to have an internet connection for the Voice Over audio files to work, and that would be unacceptable for a purchased app.

Where do we go from here?

Is the wav file in the same folder as your project? If not, give that a try.

Can you a send a screen shot of your Project Explorer window after the drag and drop?

That’s it!!!

The .wav file, which can be as big as 12.7MB, must be in the same folder as the Project before you drag it into the Properties Pane.

Thank you so much for all the help!


How I could make a program for take a video or recording sound?

@Nale, this is different question. It should have it’s own topic.