Problem updating my MAC


I have updated my MAC to Version 11.4, of MacBig Sur and I have been surprised that now I cannot include, for example, a label or other object in a container.

Could you tell me how to correct this problem.


What version of AppStudio are you using?

Can you give me a step by step to reproduce the issue?

Thanks for the prompt reply … I work with version
That happens to me even with a new project.

  1. Include a container in the Form and then a label.
  2. I select the container and it is NOT selected on the screen so it does not allow me to include the label in the container.

The rest everything works …

Just in case when I indicate, in the previous paragraph, that the rest works is that: if I take a previous finished project I can run it without problem but I cannot modify an object, that is, edit the screen.

I’m experiencing the same issue. Basically I can’t click on or select any elements/objects on the ‘screen’ - I have to select them by clicking on them in the Project Explorer. So I can’t grab them to drag them around, and that’s why they can’t be dragged into a container.

And it’s just happened to me after updating my Mac too, so I’m guessing that update has caused the issue.

I’m on the latest versions of everything! :slight_smile:


I’d love to give ones of these projects a test here. Any chance you can zip your project and send it to me?

I can do that, but it won’t help you. None of my projects respond. It’s not the project at fault - it’s the actual AppStudio that’s gone bananas. I can create an empty project now with, say, just one button, and I won’t be able to select that button. All my projects were working fine before the update, because I’ve been working on them for the past few weeks, and now, suddenly, after the update, I can’t select objects in any of them. I’ve tried loading a few that I’ve been working on and none of them respond. I can send you one, but I know they work because they were working fine before the update and were saved at that time, so I’m pretty certain they’re not going to help you.

You sure you want me to send over one of my projects?

I’d suggest you upgrade your Mac to 11.4 and see if you experience the same thing. :man_shrugging:

I’m sure that when I get home to an older Mac I have which I can’t update any further, my projects will all work fine, and I can also try on my MacBook Pro before I update, and then I can update and try again. I’m going to guess it’ll work fine on my MacBook until I update. That’s pretty much what I experienced here.

Hope that helps clarify a bit more. :slight_smile:

The same I indicate. My projects and everything worked. I agree that what has affected us is the MAC update.

You’re right - it’s MacOS 11.4 Big Sur which is the issue. We’re on it.

Phew, glad to hear that. Thanks. :+1: :sweat_smile:

We’ve just finished testing AppStudio against the final version of Mac OS 11.4 Big Sur, which was released a few days ago.

We found a problem which partially stops AppStudio from working: Clicking on a control on the Design Screen does not select the control. You can select a control in the Project Explorer and modify it in the Properties, but drag and drop does not work.

While we work on a fix, you may want to hold off on installing the MacOS update.

Good news! We think we have a fix.

Give this a try:

Let us know if it works, so we can get it out to everyone.

Dear Sirs:


I have tried it with a small application and with a large application and in both cases it works.
I have restarted, both the computer and the application to see if it works in each case, installing and uninstalling the objects and it works.



Thanks for the good news. We’ve put this on the download page so everyone can get now.

I haven’t seen the update yet. What I mean is that my AppStudio doesn’t tell me that my current version is out of date. When I check for updates it tells me:

You are using No update needed.

This happens on all my Macs (I have three - iMac at work, iMac at home, and my MacBook Pro). None of them have registered the new version.

Just to follow on from my previous post, I manually downloaded the file (from the usual location) and installed it and sure enough I now get:

You are using No update needed.

I guess the question is - why did my AppStudio not see that update and automatically advise me to download it? And is that a bug - will I automatically see the next version now?


That’s on us. We chose not to update the official number, since the fixes in only affect a few users (and only MacOS).