Problems with Phonegap

I have an Android app compiled more than a year ago and working properly. A few days ago I needed to make a modification and I could compile correctly with Phonegap but when accessing MySQL through a PHP program installed on a server I get 404 error (apparently can not read the PHP file or can not read the database). I would greatly appreciate being asked if I should compile my program in a different way. I am registered in Phonegap and my application does not have the token specified in preferences.

Now I have tried to generate a token from my Phonegap account. Then in NSB Preferences, I updated the token. Then I compiled, installed the app on Android, run the program and it keeps giving me the same error.

Have you connected the Chrome Remote Inspector to see if there are any errors on the device side?

Thanks for your answer. I will do it today. I clarify by the doubts that if I run the application in the Chrome browser of my pc, the system works well.

Excuse my ignorance. I was able to configure “DevTools” and I was also able to connect my Android device via USB cable. I can debug any web page through the URL. What I need is to debug an app that I have installed on my device. I do not know how to do it, because the “DevTools” instructions indicate only to debug a web page developed with NSB. Could you help me set up “DevTools” to debug the app that I already have installed on my device?

The chrome://inspect page should show all the apps which can be inspected.

If it’s a web app (or PhoneGap app), it should show up there.

Dear, when running Ajax (URL), as I show in the screenshot, error 404. appears. The URL executes a PHP on a remote server, to obtain User and Password recorded in a MySQL database.
I will be very grateful if you can help me with this. I can no longer update and compile my app because it does not work.

  1. Have you checked if the file in the path is actually there?

  2. What happens if you try https instead http?

Yes, the route is correct. Also, if I run the URL from a browser, it returns the data I need. The problem is when running Ajax. This afternoon I will try https.
Thanks and regards.

I have tried again with https and I still can not access the database. This same application, with a compilation from a year ago works well today. I do not know what else to do anymore. I can not improve the code because I can not compile.

I want to tell you how I solved the problem:

  1. I created a new project
  2. I copied the contents of the config.xml file
  3. I closed the project and opened the project that did not work
  4. I pasted what I had copied into the project config.xml file that did not work
  5. In the “Version” property I added “cli-6.5.0”
  6. I compiled the project again and now it works for me.

Thanks for the help and regards.

It might be interesting to do a compare of the old project and the new to find out what is different.

I’m glad it’s working!