SQLImport not saving data


Hello -

I am deploying an empty db with my app. Upon start I run a sqlimport to load data into my tables. The data looks good and works as expected.

When I close the app and restart, my data is no longer stored in the db. I am using the NSB.overwritealways on the import. Ideas on why my data is not saving?



In my experience, this is normal behavior. Data changes in web sql tables created within the app persist after app restarts, but data changes in imported tables do not.

Kind regards,


What differentiates the difference? I am updating the same tables. I want to persist imported data, how can I achieve this?


I can only confirm that I’ve experienced the same behavior. I’ve worked around it by using imported tables “as is”, then creating new tables inside the app then moving data into them and/or editing data in those tables only.

This may be an AppStudio issue, or it may be a web sql issue. George may know.

Kind regards,


NSB.overwritealways means overwrite the database when the app starts, which sounds like what you are seeing.

Have you tried the other options?



I figured out the issue. I made sure my import data version matched the same version of my db and the data is now persisting.


Hey, that’s great news. I need to look into that.