SQLite and WKwebview

I appreciate you can help me.

Just in case I tell you this is for iOS apps.

I have worked sql applications using plugin:

Originally it was created with the following:

db = SqlOpenDatabase (“calculator.db”, “1.0”, “Calculator Data”)

Now I have tried to read it, after the device is ready and the installed plugins with the following:

db = SqlOpenDatabase (“calculator.db”, “1.0”, “Calculator Data”) indicates that “SQLite not suported”

with the following cases it works, that is, I can create, write and read but not the old database:

db = SqlOpenDatabase (“calculator.db”, “1.0”, “Calculator Data”, 1)
db = window.openDatabase (“calculator.db”, “1.0”, “Calculator Data”, 1)

db = window.sqlitePlugin.openDatabase ({name: “calculator.db”, iosDatabaseLocation: 0})

db = window.sqlitePlugin.openDatabase ({name: “calculator.db”, createFromLocation: 1})

db = window.sqlitePlugin.openDatabase ({name: “calculator.db”, iosDatabaseLocation: “Documents”}, PaLaBDArrancaSql3, ErrorPaLaBDArrancaSql3)

db = window.sqlitePlugin.openDatabase ({name: “calculator.db”, iosDatabaseLocation: “Library”}, PaLaBDArrancaSql3, ErrorPaLaBDArrancaSql3)

It has always worked fine but now that I am using:
“cordova-plugin-wkwebview-engine” databases that were created before that are not read by the original plugin. I can create others but I can’t read the original one, even though it exists.
I know it exists because I count “cordova-plugin-wkwebview-engine” removal, it reads them without problems.

The same happens to me with the plugin “cordova-sqlite-storage” with spec = “5.0.0”.

Could you help me to make the sql recognize or find the old database?

Thanks for your valuable help.

The new plugin requires another parameter doesn’t it? The location parameter?

If correct, the location parameter. At the top you will see that I have tried them but could not read the previously created database.

db = window.sqlitePlugin.openDatabase({name: ‘my.db’, location: ‘default’})

or in my case for ios

db = window.sqlitePlugin.openDatabase({name: ‘my.db’, iosDatabaseLocation: ‘Library’}, successcb, errorcb);

the parameter can take the values:

All tried and failed to read the previous DB. So I ask for help. Of course I could be doing something wrong too.

That is, I require your support and again thanks for the help.

one and two, the translator put it. Understand that they were numbers, that is, 0, 1 and 2. My English is not very good, so I prefer to use it. .

I think there was a blurb in the docs that if you were using the new version of the plugin to access an older database you had to set the location to something else. I just don’t remember what it was.

If you please remember or someone remembers it too, I would appreciate sharing it, I think this is of general interest.

As you can imagine, I will be quite grateful.

I will keep trying.

What version of Cordova iOS are building against? This plugin is not supported for iOS > 6 according to GIT page for the plugin.

Thanks for the indication. I use what Voltbuilder presents so I assume it is the latest in systems …
I will appreciate if you can tell me what would be the solution to be able to read the DB that is in the sql webview environment.

VoltBuilder uses the current Cordova release, though they often have the next one available already: