Update from Version 3.3 to 8.x

Hello,

i still use appstudio 3.3. I would update to the actually version, because the application.cache is obsoleted. But when I open my projects all buttons, combobox and some other are gone, because they are in jquery mobile. I have written many apps, about 20, I don’t want in all apps to renew button etc.
Is there another way or why do appstudio 8 this components actually and let it not in jquery mobile for the time?

regards

Udo

I take it you are still using the jQuery Mobile 1.3 controls? That was replaced by jQuery Mobile 1.4 back in 2014.

It might be a good idea to start by opening the projects in AppStudio 4, which will update them to jQuery 1.4:

Version 4
Mac: https://dl.dropboxusercontent.com/s/hqwzc7qi5s75ri0/AppStudio4.dmg?dl=1
Win: https://dl.dropboxusercontent.com/s/uqa85qbwheukhku/AppStudio4.exe?dl=1

From there, it should be easier to get to AppStudio 8.

Of course, this is not the final solution. jQuery Mobile 1.4 is no longer supported by its authors. It has not been updated in many years. It is no longer compatible with modern web browsers, since the version of jQuery it used is no longer supported.

Thank you for the tip. It could be a solution, but I think it is a never ending story. When I update my programs, in that time, it will be release the next versions of bootstrap, Appstudio or both. I am a hobby programmer and so the problem is the time to program in life. For the first time I’m waiting until the jQuery Mobile 1.3 controls are not working on my mobile.

Thank you for your effort!

best regards

Udo