After uninstalling demo of version 8.1, cannot open old nsx files

I attempted to try out the demo for vs 8 but had some problems so uninstalled it. Now I cannot open any of my prior appstudio files with a nsx extension. I am using vs 6. I still have several of my old appstudio.exe(x) files from past years but they don’t help and I can’t associate them with nsx. I would really appreciate help or point me in the right direction. It is probably pretty simple. Thank you.

From what I understand, once you have opened your old projects in a new version of App Studio there is no going back to using an older version of App Studio.

Did you try double click on .nsx file in Windows File Explorer?
I very vaguely remember having had this issue too, years ago …

Once a project is save in AppStudio 8, it’s not possible to open again in older versions.

What problems are you running into with 8?

(Version 6 by now has many problems with modern browsers and tools).

Thanks for the reply and for others who also did. I also installed the 8.1 demo on my laptop and after a lot of fiddling around got my nsx files to open so I think I may be able to use it now for testing. However, my main computer on which I had uninstalled the demo still has the problem of not being able to open any of my previous nsx files. I have tried every method I can think of to associate appstudio.exe to those files but have come up empty. This means I cannot use appstudio there until I can fix it. I know there must be an answer but I am dead in the water for now. George, you might try installing/uninstalling there and see if any of what I have said applies. Is there a vs 6 installation file you could send for me to try to get back to my starting point? The “exe’s” I have won’t open anything. Incidentally, the reason I uninstalled the demo was because it would not open my nsx files. Thank you very much.

Thank you William but I was never able to open any previous project with the demo. Very frustrating. If what you say is true, existing users should be cautious in trying a new demo. Read my reply to George.

That and several other methods. Nothing has worked.

What would you like to concentrate on first? Opening the old projects with AppStudio 6, or opening your current projects with AppStudio 8?

You nailed it and brought the issue to its lowest common denominator. No wonder you are the boss. I believe I would prefer to pay for the discounted upgrade to vs 8 that includes 4 months of a volt subscription. Actually all of my projects are on the same level so that I would need all of them able to be opened with the new version. I believe my testing so far on my laptop has been positive. And I want to be able to make native apk’s and ios apps. I certainly hope those things can be done seamlessly since I am old and don’t have the capacity anymore. Thank you, George, and your team. You guys are awesome.


Good pick. Let’s take one of your projects that isn’t working on AppStudio 8 and figure out what’s going on. With that done, I bet you’ll be well on your way to fixing the others.

Tell us what’s going on with that project. If you want to share it, zip up the project folder and send it along.