Ajax Voltbuilder


I have an app that runs on the web using ajax commands.

I created a free account on voltbuilder and made a build for android. But the application did not work the ajax commands.

Can anyone tell me if the Voltbuilder paid account works with ajax commands?

Yes, the free account supports ajax. You’re probably having Content Security Policy (CSP) issues.

Have a look at the remote console - you probably have error messages there.

When I run the app generated by voltbuild the error that is returning in the status of the ajax post is undefined.

When I run the app on the web, I run it from the url where my php is, and it works just fine.

Now in the app generated by voltbuild where do I configure the url for it to find the php I use in the ajax post?

I am expecting there is also an error to be seen on the remote console. As @PPetree said, I expect it’s a CSP error. Native apps have different security requirements than desktop apps.

Here’s how to look at the remote console. It’s a very useful debugging tool!