App only loads on every second attempt

I’m running the latest version and using VoltBuilder.
I’ve just noticed that my app only loads properly on every second attempt. Here’s what is happening:

  1. I download my apk file and install it.
  2. Try and open the app. The splashscreen shows then after it has shown, the phone returns to the phone home screen (fails to open app).
  3. Try to open the app again, and splashscreen shows and app loads properly (app opens).
  4. I then go back to phone home screen and try to open app again. Splashscreen shows then phone returns to home screen (fails to open app).
  5. Back to 3) and continues

When the app fails to open, it never shows my first form. It returns to the phone’s home screen after splashscreen shows.

Has anyone else noticed a similar issue?


I figured out what was causing the issue.
One of the bluetooth plugins i was using was updated recently and this was causing all sorts of issues.
I’ve since removed that plugin.

Which plugin was it? Is this on Android or iOS?

It is for Android.

The plugin that first started causing issues was this bluetooth plugin. As soon as i used any command from this plugin, the app would crash and return to the phone home screen.
Then i noticed another bluetooth plugin i use was causing the app to close (return to phone home screen).
I am not sure if there is some sort of clash of these plugins causing this, but i’ve been using these plugins for years. However, one of them was updated 2 weeks ago.

The reason the app loaded on every second attempt (first post to topic) was because my app turns bluetooth off when the app first loads and since it uses these plugins to do this, it crashed. I then ran the app again with no bluetooth on and everything was fine. I then turned bluetooth back on and tried to load the app, and it crashed again. I worked out that the bluetooth plugin issue was the cause of the problem.

Everything was working fine up until i started updating this app the other day.

I’m really stuck now, and have to make changes now for a customer.
Can i download a previous plugin version and try use that?

Any help is greatly appreciated.

Have you opened an issue in the GitHub repo for the control? This sounds like something for the author of the control to look at.

Have sent a message. Hope to hear back soon from them.

Right now, this is looking like a problem with the plugin, not VoltBuilder.

The same issue happens when building with PhoneGap, even with an older version of AppStudio.

Good luck with the plugin developer!