AppStudio 7.2.1 released!

We’re pleased to announce that 7.2.1 has been released.

It includes new features and some bug fixes.

  1. BS4: New Toast control
  2. BS4: Select: No longer creates empty values for item
  3. BS4: Updated Bootswatch themes
  4. BS4: Switch: New Bootstrap native Switch replaces of Titatoggle's Fliptoggle.
  5. Code Windows: Markdown (.md) files can now be edited.
  6. Deploy: loadType is now implemented.
  7. Deploy: new loadType: noload
  8. IDE: eslint dialog is reused (so there are never two visible at once)
  9. IDE: Project CSS is now marked up as CSS.
  10. IDE: Rare project corruption issues fixed - now it self fixes.
  11. IDE: Update copyright to 2019
  12. Project Explorer: Files can now be dragged and dropped. Will be deployed to the project's root directory.
  13. Project Explorer: Folders can now be dragged and dropped. Will be deployed to the project's root directory.
  14. Samples: Volt users - bug fixed in password check.

The easiest way to get the update is on the Help menu – “Check for Updates…”

WIth the old FlipToggle, the size of the button can be set. Is there a way to set the new Switch button size easily?


I cannot get many of the controls onto a form with this update, eg Select, Slider, Switch. And I cannot select or move the controls that I can get onto the form, eg Checkbox…

I have tried both an existing project and a new one. I have rebooted after updating.

When I shutdown the new test project (with just one control on a form) and reopen, I get the corrupted project message each time.

We will research that - this is newly added to Bootstrap.

@silvercoder - can you give me a step by step to reproduce what you are seeing?

Try putting this in the style property of the control:

transform: scale(2); left:50%;

This doubles the size of the control. Since the doubling happens from the center of the control, we need to reposition the control.

It seems the problem occurs only after trying to add the Switch to a form. Everthing goes haywire afterwards.

Windows 10 Pro 64bit

Thanks - we’re on it.

AppStudio has just been uploaded - it fixes the issue.

Seems to work OK now.

Can now use onclick for both Android and iOS. Previously I had to use ontouchend for iOS to make sure it worked properly.

The styling solves the button size issue. Thanks.