[Bug] inconsistent handling of ApplicationStorage

during my evaluation I’ve found that it is possible to retrieve a key-value store for the dashboard without errors. The results are meaningless, but you may prefer returning “404 Not Found” like in other requests.

[Edit] I can also retrieve a single entry from the mentioned key-value store - which is even less meaningful

I don’t believe I understand. Could you give me an example?

well, it worked by just providing “RpYCMN” as the application id - surprisingly, however, I wasn’t able to reproduce the situation today…

even stranger: now it works again

GET {{dashboard_url}}/api/storage/RpYCMN

gives me

  "Array": [
  "Number": 123,
  "Object": {
    "firstName": "xxx",
    "lastName": "xxx"
  "SimpleString": "ABCD"

I "xxx"ed away the name shown in the response - but there is one.

Let me see if I can find out why it did not work in the first time (at first, the request responded with an authorization error - s.th. I would expect)

This is not a bug. You just requested and received the application storage for the dashboard. It looks like just some old tests made by one of our developers. I don’t see any problem here.

I see,

so it’s perhaps not intended, but a non-hazardous side-effect of your implementation? And probably even safe to be used?

Everything here is working as intended. You are welcome to use application storage for your own apps.