Build failed (manifest issue)


I haven’t done any work for a while on one of my apps which uses a bluetooth plugin.
The plugin i am using is cordova-plugin-ble-central

When i try to make native app with VoltBuilder for Android, i get the below message which i never use to get

Am i missing something in my config.xml?


Have you checked whether your plugins are up to date?

A summary is show at the end of the log where you can see this.

Thanks for your reply.

I am not sure which parts shows if the plugins are up to date:
I see this though

* What went wrong:
Execution failed for task ':app:processDebugMainManifest'.
> Manifest merger failed with multiple errors, see logs

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at

Deprecated Gradle features were used in this build, making it incompatible with Gradle 8.0.

You can use '--warning-mode all' to show the individual deprecation warnings and determine if they come from your own scripts or plugins.


18 actionable tasks: 18 executed
Command failed with exit code 1: /platforms/android/gradlew cdvBuildDebug -b /platforms/android/build.gradle
Error: Command failed with exit code 1: /platforms/android/gradlew cdvBuildDebug -b /platforms/android/build.gradle
    at makeError (/node_modules/execa/lib/error.js:60:11)
    at handlePromise (/node_modules/execa/index.js:118:26)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at async (/node_modules/cordova-android/lib/builders/ProjectBuilder.js:316:20)

2022-08-11 23:32:57,056 - FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':app:processDebugMainManifest'.
> Manifest merger failed with multiple errors, see logs
See log for full details.
2022-08-11 23:32:57,056 - Build failed ee4415da-1630-4bbe-9228-04e126d274
2022-08-11 23:32:57,982 - Output: Package          Current  Wanted  Latest  Location                      Depended by
cordova-android   10.1.2  10.1.2  11.0.0  node_modules/cordova-android  ee4415da-1630-4bbe-9228-04e126d274


Looking at your log, I see these messages:

> Task :app:processDebugMainManifest FAILED
/app/platforms/android/app/src/main/AndroidManifest.xml:16:5-108 Error:
	Element uses-permission#android.permission.ACCESS_COARSE_LOCATION at AndroidManifest.xml:16:5-108 duplicated with element declared at AndroidManifest.xml:13:5-81
/app/platforms/android/app/src/main/AndroidManifest.xml:18:5-95 Error:
	Element uses-permission#android.permission.BLUETOOTH at AndroidManifest.xml:18:5-95 duplicated with element declared at AndroidManifest.xml:14:5-68
/app/platforms/android/app/src/main/AndroidManifest.xml:19:5-101 Error:
	Element uses-permission#android.permission.BLUETOOTH_ADMIN at AndroidManifest.xml:19:5-101 duplicated with element declared at AndroidManifest.xml:15:5-74
/app/platforms/android/app/src/main/AndroidManifest.xml Error:
	Validation failed, exiting

You might want to play around with your edit-config statements. (I have not tried this myself)

Didn’t have much luck with changing the edit-config statements. Tried to use code such as from here and here as a guide but couldn’t get anything to work, unless i am looking at the wrong thing.
I might have to look at using a different plugin.

After updating to the latest NSB and building for Android 12, everything works fine.