Cache error 3.0.0 what is it and how do I track down the cause?

I suddenly started getting the following error message when I load a newly updated App to my server.

Update unsuccessful: cache error
2017-07-07 18:35:49.371348

Can anyone tell me how I might track down the cause?

Start with looking at this article:

It’s item #1.

Thanks. I should have thought to look there. I followed all the instructions.but still not solved.

In the debugger I get:
Application Cache update failed, because could not be fetched.

This php file is in the manifest and it is on the server in the correct place.

Is it also in the folder you are deploying from?

Yes it is in the folder I am deploying from.

I just deployed another App I have and I get a similar error.

Update unsuccessful: cache error
2017-05-17 20:43:45.883244

Also deployed an 1 year old version of the App (not edited for a year) and got same error.

I am suspecting some setting on the server. I have asked the server help.
These Apps have been working for a couple of years.

What’s the error message in the console of the other apps?

Have you tried clearing the cache?

Error in year old version is:

Application Cache update failed, because could not be fetched.

and from the other App

Application Cache update failed, because could not be fetched.

For the version with insertuser.php in the error I just changed the name to insert.php and the error message then was:

Application Cache update failed, because could not be fetched.

But I haven’t been able to find an “acceptable” name for Uservalidate.php

Does using https instead of http help?

Did you clear the cache?

Yes I cleared the cache.

I have finally had a breakthrough with the server support. Recently my server was migrated to another server. This is possibly the cause of the php problems. I have now fixed one problem with one php script. The support informed me that the new server required specification of the user agent. I did that and it worked. I have asked the support to look at the other php scripts and tell me if there are other changes needed. I will let you know how I go.

Thank you for your help.

The server support told me "You will need to debug this code with your developer so that it is compatible with our cPanel envrionemt.” I asked them to list how their cPanel environment differs from the previous server cPanel environment. They have not replied. I will have to work on each of the PHP scripts and try and find out why the new cPanel is rejecting them.

This is very frustrating. I had my App working well and had the Sydney Showjumping Club beginning to use it. This is the biggest club in Australia. The migration to a new server has crippled my App. If indeed that is the problem.

Thanks for your help.

Does cPanel give you the option to specify which version of PHP you want to use? If so, and if it’s set to the most recent, try putting to an earlier version temporarily. Not too long ago my web site suddenly broke because my provider got the itch to spontaneously update PHP and I had code in my site that wasn’t compatible with the latest version. Granted setting it back to an earlier version wasn’t the best solution, but it got my site back up and running until I could fix my code the right way.

Thanks Eric

The PHP version was set at 5.4. I changed it to 5.5 and most of the problems appear fixed. The server support assured me that the current php version matched that on the previous server. I just checked again and it was set to 5.4 not 5.5 which was the old server setting.

So the cache error when updating a newly deployed version of my NSB AppStudio App meant I had the wrong php version set.

Either way that’s rather old, seeing as they are on 7.1.7 now. Even for the 5.x branch that appears to be outdated, as they just released a 5.6.31 security patch. Does your system require a lot of PHP pages or just a few?

I have over 20 php scripts that are mainly reading and writing data to an sql database on the server. I will experiment with changing the php version.