Cannot deploy to local folder

I have a problem where I cannot deploy to a local folder. I have outlined my setup below.

  • Operating System: Windows 10
  • NSB App Studio version: Classroom edition
  • Deployment to Volt works fine
  • Start in Desktop Browser works fine

“Run > Deploy to Local Folder” menu option is disabled

The “Deploy” tab on “Tools > Preferences” shows “Global Location” radio button set but “Project location” radio button disabled.

I have tried creating a new empty project and also opening an existing old project but the behaviour is the same.

Is this a limitation of the “Classroom Edition”? If so, how do I change the license key for App Studio as I tried uninstalling App Studio and re-installing and the license key already entered remains persistent.

Thank you.

1 Like

Yes, this is a limitation of the Classroom Edition.

What do you need to do?

Ok. I have a non educational license that I could try using instead. Is it possible to reactivate with a different license key?

Alternatively, If you could tell me where the built files are stored after hitting “run in browser” that would solve my problem.

I just need to be able to grab the built files so I can upload the app manually to a server. I can’t use the inbuilt FTP uploader due to security settings on the server.


For a local run, the files are sent to a temp folder which is tough to find (and may not work quite right for a deploy).

Any chance the server would be happier with SFTP?

Is there a way I can reset App Studio and use a different key?

You have to do a complete uninstall:

Ok, so my other key is too old so it doesn’t work on latest NSB App Studio…

So I’m trying to use the inbuilt FTP deploy with the educational licensed version and even though I’ve added in all the working FTP settings into the global deploy settings, the “Run > Deploy to FTP/SFTP Server” option on the menu is still greyed out.

I got the impression from the previous messages, I could use FTP deployment?

Please advise. Thank you.

Sorry - the Classroom Edition does not allow you to ftp/sftp to another site.

Can you email me a screenshot of your About screen? Let’s see what we can do.

Here you go…

(image deleted)

Thank you - I’ll respond to you directly.


Deploy to external FTP is indeed turned off for the Classroom Edition. The idea of the Classroom License is a single, less expensive price for a whole room of people. In exchange for that, you lose features which would allow you to make commercial apps.

What is your use case here? Maybe we can think of a workaround.

Sorry for the slow reply.

Essentially it is a legacy commercial app I have to occasionally do updates on. It was a project I inherited many years back. It is a rate calculator app for TV/movie extras who are part of the BECTU/FAA union.

I have an old license for an old version of appstudio (v5). Should I download the old version of app studio? I’m worried I may have updated a couple of components this year that might not play nice with the old version of app studio.

If it’s helpful, I did create this series of YouTube videos for App Studio while I was running a module for University of Surrey (hence why I have their app studio education licence):

Worth an upgrade to a commercial license?? (Don’t ask, don’t get) :slightly_smiling_face:

Jon Jackson
07843 671 506

That’s a great set of Tutorials. Did you just teach the module once, or is it ongoing?

OK if we share it with all our users?

Thanks! Please do, I deliberately left it all public.

I teach one or two Mobile modules every year at Bucks New University and
I’ve done it once for the University of Surrey so it will offer some
long-term value. I’ll add to the tutorials if there is demand from students
when I next run the module.

Any thoughts on the license issue?