Can't "mangle" function names with obfuscator

I added


to my obfuscator settings, but my function names are not being mangled at all. Is there a different way to do this? For example, I have selected js-obfuscator-low and have the following under obfuscatorSettings:

"compact": true,
"controlFlowFlattening": false,
"controlFlowFlatteningThreshold": 0.75,
"debugProtection": false,
"debugProtectionInterval": false,
"disableConsoleOutput": false,
"reservedNames": [],
"rotateStringArray": true,
"seed": 0,
"selfDefending": false,
"sourceMap": false,
"sourceMapBaseUrl": "",
"sourceMapFileName": "",
"sourceMapMode": "separate",
"stringArray": true,
"stringArrayEncoding": false,
"stringArrayThreshold": 0.8,
"unicodeEscapeSequence": true



If you want to override the js-obfuscator-low settings with your own settings, set obfuscation to js-obfuscator-custom. Put your new set of parameters into obfuscatorSettings.

Thanks. I did try that, along with all of the other settings, and the function names were never mangled.

Am I using the wrong choice?


I don’t claim to know everything about this library. The documentation for the library isn’t much help here.

I tried pasting some code into this online tool which uses the same library. It didn’t mangle my function names either.

You may need to do some more digging and experimentation.

Perfect! Thanks!

It’s always good to get confirmation that it isn’t just me :slight_smile: