Can't 'Save As' sample project


#1

I opened a sample project (JS) and wanted to resave it to my desktop so I could play with it. It looks like it is resaving, as there is a new project folder (with .appstudio name) but all it has in it is .gitignore.

Advice?


#2

I just tried the same thing here and it worked fine. Can you give me a step by step?


#3

Sure. Working on a Mac. So I open the Sample file (for datatable). Playing around with it - changing some code, seeing what happens, etc. I want to save my changed copy -

  1. so go to File > Save Project As (see image 1).
  2. It gives the name Datatable.project - I change the name to DatatableF9.project and click Save (see image 2).
  3. here is what it saved (see image 3).

#4

You’re right - I see the same thing. It’s MacOS only. We’ll get this fixed right away.


#5

Thanks. Let me know when it is ready as I am using it in class Monday (tomorrow of course!).


#6

I have a workaround for you:

After you load the sample, go into Project Properties. Set the value of manifestFile to ‘appcache’. It should then save properly.

Obviously, we’re going to fix this quickly. Let me know if the workaround works!


#7

Lovely! I have several students having an issue that when they save their project, it doesn’t save any of the contents of the project folder. I wonder if this is the same issue? I will ask them to try this and let you know. All the students are on Macs.


#8

We’ve just uploaded 7.3.0.1, which fixes the Save As problem.


#9

Very cool! Thanks - I’ll get it after class today (lesson learned - never download new software right before a class you are using it for a demo in … :slight_smile:

Cindy


#10

How does one update appStudio? I don’t see an update anywhere in the menus.


#11

Use ‘Check for Updates’ in the Help menu.