Chrome Debugging, WASM, SQLITE

It seems time has run out on the Chrome Debugger for me…which is a disaster in terms of rapid development.
I tried to downgrade Chrome on my PC and also downgrade AppStudio to version 8, but no good.
I’m unable to get the SQLite WASM working as I’d need. When I did get a sample working earlier I find it difficult to ‘see’ the tables as I used with WebSQL…

Is there any general update as to progress in this area…as I’ve run out of ideas here!

Unfortunately, I have bad news here. Since Google is removing SQLite from Chrome, the debugger for it is also being removed. That’s a pity - it was really useful. (I used it a lot too)

Downgrading AppStudio won’t help here.

What problems did you run into with SQlite WASM? We’re continuing to improve our support for that and would love to hear from people who are using it.

I’m a bit worn out after a long day here today, but i have 2 areas of difficulty.

  1. Migrating my existing projects to something compatible with WASM

  2. If and when i complete point 1, then how do I view tables ( and contents) and run queries in debugger mode on Chrome…or is that ever going to be possible again? I realise i could create grids in my projects to show table contents etc but it’s soooo much more work than now.

  1. What kind of issues are you running into?

  2. Don’t expect to be able to view tables using anything in Chrome. I’d build some extra functions into my app to view tables, which I could call from the Chrome Debugger Console.


Ok, I’ve been experimenting - while trying to do my day job :slight_smile:

I’ve found issues and resolved some…


Works in apk (and used to work in Chrome browser):-

s = Join([damnumvar, damnamestr],",")
sqlList[i+2]="INSERT INTO damagemis(damnum,damname) VALUES ( " & s & ");"

This needs to change to this to work on SQLite WASM :-

s =[damnumvar, damnamestr]
sqlList[i+2]=["INSERT INTO damagemis(damnum,damname) VALUES (?,?);",s]

Something weird going on with select/where statements… can’t get it to work yet
Simple things like “select * from drivers where name = '” & namestr & “';”

For the life of me, i can’t get it to work…with different tweaks…

Is there a definitive guide to differences between SQLlite in WASM versus the regular SQlite I’ve used so far ?

Tip : If you’re pasting code, html or config files, surround the code with triple back ticks (```), before the first line and after the last one. It will be formatted properly. (We fixed it for you this time)

I got the SELECT Query functioning now

In the ‘old;’ system using a query like :-
SELECT * FROM Tablename where Field1= 'ABC';
would work

Now you MUST name any fields in the ‘where clause’ in the ‘select clause’

SELECT Field1,Field2,Field3 from Tablename where Field1='ABC';

or even
SELECT *,Field1 from Tablename where Field1='ABC';

Both of these will now satisfy the correct syntax while supplying the output fields to the called function after.

Such small changes, but not ones I was aware of. If there is any documentation specifically for ‘SQLiteWASM’ query syntax, please let me know.
I’m running on ‘trial and error’ at the moment

I haven’t seen any documentation which details the differences.

We’ll do our best to document everything which comes up.

Thank you for analyzing this one!

@Neil_HNF - I tried to reproduce your SELECT issue. Unfortunately (or perhaps fortunately) I was unable to reproduce it.

I used SQLSample1. Run it, created the database, than typed the following into the console:

> sqlList = []
> sqlList.push(["SELECT * from customerData where name='Customer0';", dataHandler])
> Sql(DB, sqlList)
> console.table(DBRecords.rows.rows)

Screenshot 2024-05-05 at 10.15.51 AM

Hi George,
I think my issue may have been with my variable in the Where clause. I’ll look into it further on Tuesday!