Code.js and index.html are not updating - 8.4

I noticed in 8.3 and 8.4 my code.js and index.html in my project are not reflecting changes made to my project javascript and designer elements. I see this difference when I run in desktop as well as building an apk in VoltBuilder.
How doe these generated projects get updated?
This project is in source control with Bitbucket but that does not seem to cause a problem with any other files.


Are you reloading the project after changes are made in BitBucket?

I don’t understand what you mean. I am the only one developing the project and only do commits of the code for backup and versioning purposes. Do you mean reopening my project in AppStudio?

Do you think there is a permissions problem? This is a project that was last worked on around 10 months ago

This is a long running issue with Chrome (I think maybe others too) code. Js and index are updating on the server but not in the browser. I’ve found disabling firewalls and anti-virus software helps,… sometimes.

My problem is that code.js and index.html are not updating in the development files even before I try to run them on the browser OR Volt Builder.

I just copied the project over to my Mac, and opened the project with Appstudio 8.4 there. I get the same result as Windows. On both Windows and Mac, opening in Chrome, the changes I made are not present in the app. On both Windows and Mac, opening in Firefox, the changes I made ARE present but the files below in PTS folder are unchanged and therefore are not reflected on the apk file built in Voltbuilder.

My project directory looks like this:
---------nsb (dated 10/24/2020)
---------toolbox (dated 10/24/2020)
---------code.js (dated 10/23/2020 but does not match the code in forms folder)
---------index.html (dated 12/24/2019)
---------manifest.json (dated 12/24/2019)
---------pwa.js (dated 12/24/2019)
------PTS.project (dated 10/24/2020)

The dates are off and code is mismatched on what appear to be the generated files in the PTS directory.

Have you tried clearing cache on the browser?

Yes on all browsers on both Windows and Mac

I’m not sure I understand.

Do the changes show up AppStudio itself?

When you do a fresh local to Deploy to Chrome, do they show up?

  1. I open the project.
  2. I change some code and or controls on a page.
  3. I save the project.
  4. I look in the project folder at code.js and index.html and the changes I made in step 2 are NOT reflected.
  5. I do a local deploy to Chrome and the changes are NOT reflected in the UI or in code.js in the Chrome developer tools. (I don’t know what ‘fresh’ means. Am I missing something?)
  6. I have cleared cache several times in Chrome.
  7. I launch the local deploy in Firefox and besides the error I receive about my Sqlite database not being supported, I DO see the changes to the UI. However code.js in Firefox developer tools does NOT reflect the changes.

Additionally if I deploy to Android via APK file built in Voltbuilder, the changes are also NOT reflected.

Try clearing Chrome’s cache again and restart Chrome. If that does not do it, do a reboot as well. Seems like Chrome does not want to give up the old version.

Tried all. Still not updating code.js

Can you zip the project folder and send it to me? Let’s see what I get.

what email can I send it to?

This issue with code.js seems to have resolved with several restarts, and forced cache clearing for several hours.