Creating desktop app

Hi,

I’m currently using the latest AppStudio version and running on Windows.
I followed the wiki on how to create a desktop app. It seems to follow through and it says ‘Installer successfully created. It is electron/dist/ElectronWeather-1.0.0.exe’.
No exe file gets created. I deleted the electron folder and ran it, and it’s still not created.

Is the sample outdated? Or is something else missing?

Thanks

I’m seeing some odd results here, too.

There are a number external dependancies in the build chain for this. Give us a chance to review these and see what the issue could be. I have opened an issue.

Ok, no worries, thanks.

The problem seems to be with the ElectronWeather sample.

Can you try creating a new project with just a button and see if that builds?

I created a new project with a single button, and the result is the same.

  1. Did you try it a second time? Did it work then?

  2. Does Run Desktop App using Electron work?

I tried a number of times, and it didn’t work.
If i run Run Desktop App using Electron, several black windows pop up and then disappear. There are no messages.
If i run Make Desktop App for Distribution using Electron, several black windows pop up and then disappear, and a message box shows saying that the installer was successfully created in the project folder, but nothing is there.

Thanks

Thank you. So far, I have no luck reproducing your results.

We’re working on a new build of AppStudio with more error logging right now. That should give us more information.