Deploy new version got error

when deploying my new compiled version to windows server we got error from code.js
looks not updating.
the only way to clear that error is to clear browser cache, and that is not covenant to ask every user to do so, and the problem even worse because the users access my app using store app (webview) and to clear the cache they have to uninstall/ reinstall app from phone store

is there solution for this? is there a way to embedding code.js into index.html ?

Please post the actual error.

error messages says:
Uncaught ReferenceError:
Button10 is not defined.
line 1 coloumn 829340

I’m saying: I removed Button10 and its’ functions from new version, that means code.js still not updated

Where are you deploying to?

my remote windows server (iis)

I did some thing to force updating:
-change code.js name to code123.js, also change it in OfflineApp.appcache and in html.index
-change OfflineApp.appcache serial datetime
-refresh browser (looks updating and downloading resources), but when open and view index.html source, code.js not changed to code123.js, still like it was before -> script src=‘code.js’>

What happens if you deploy to the Volt server?

If that works OK, you make have problem with the configuration of your server.

(I assume you have made sure that all references to Button10 are gone from your code)

no ref to Button10 at all
I did not tried deploy to Volt yet.

work around: adding random number to page request such as: mydomai/game/?a=123
force updating and no error, but not the right solution for my game users as they are using phone store app
I will try move web app to another directory and in original webapp dir I will put simple html page to redirect to the new directory with random argument parameters such as mydomai/game/?a=123

I can understand why this works, but it should not be necessary.

AppStudio puts a time stamp in the manifest, so it is different every time. If the server is not acting on this, I suspect there is a problem with the server.

time stap good to load resources, but browser keep caching index.html

regarding deploying to Volt: I got an error
Application Cache Error event: Resource fetch failed (404)

one more thing I need to know about Volt, as it is https, does my app websocket have to be secured (wss)?

It really sounds like your server is not handling caching properly. Check this:

It’s not finding HTypeS.Png since the actual file name is HTypeS.png (notice the upper case P)

Yes, Volt is https. Your call to also needs to be https.

Regarding not finding HTypeS.Png, it is already named HTypeS.png year ago, this image is in images folder
I check the name in folde and it is small p, I even removed the folder name (images) from manifest and compile, !! the images from image folder still listed in OfflineApp.appcache

Regarding Volt subscription, I have one time NSbasic purchases and when deploy to volt it says not subscribed !

please check the manifest portion here, it listed the image name 3 times and one of them is upper P

images/HTypeS.png <--------------------
images/HTypeS.Png <--------------------
images/HTypeS.png <--------------------

What do you have in Project Properties…manifest?

I have opened .nsx in text editor and search for images with .Png and reassign file name again for each image
now its ok

Thanks for the good news!