Embed Reddit widget into AppStudio

I am trying to embed a reddit.com widget using the HTML property. I found code for a reddit widget at: http://embed.redditjs.com/#subredditw

The site provided a script and it worked when I tested it out in W3 TryIt Editor (code provided below)

However, the widget does not work when I try to execute it in AppStudio. I have tried 3 main things:

  1. Posting the entire code (seen above) in the HTML property
  2. Posting just the script tag ( )
  3. Posting the above, but replacing the script with an iframe.
  4. Putting the code into an HTMLview as well as a Container had no results either.

I know the code is not the problem, it’s working flawlessly on W3 TryIt editor. Is there an issue with how I’m inserting it into my AppStudio app?

Note: Using the chrome debugger reveals that the server responded with a status of 404.

Any help would be greatly appreciated, thank you for your time.

Here is the code provided by http://embed.redditjs.com/#subredditw