Engine name Android 12 vs 13

If I use

<engine name="android" spec="12.0.0" />

then I get this error from the Play Store.

If i change the engine to “13.0.0” then my NSB build fails.

Tip : If you’re pasting code, html or config files, surround the code with triple back ticks (```), before the first line and after the last one. It will be formatted properly. (We fixed it for you this time)

We will have a look.

sorry, i remember that now.


The latest engine is 12.0.1.

Remember that the engine number does not correspond to the Android release number. 12.0.1 is the version of the latest cordova-android library, which is used to make the apk.

There’s more here.

After changing the engine to 12.0.1, I still get this error ‘Your app targets Android 13 (API 33) or above.’
I think that’s what the above reply was implying I do.

Are you sure that’s the message you are getting? When I check our logs, it looks like you’re getting this:

UserError: FAILURE: Build completed with 2 failures.
Gradle error. See log for more information.
1. Make sure all plugins are up to date (see end of log)
2. Check for obsolete plugins: https://volt.build/docs/android_12/#obsolete-plugins
3. Look for plugin conflicts

I think the actual problem is that phonegap-plugin-barcodescanner does not work with the latest Android.

If you’re looking at my latest build, that’s true, I changed back to the original plugin so I could at least use a debug version.
But when I got the original PlayStore error, I had followed the VoltBuilder document ‘Building for Android 12 and 13’ and changed the obsolete plugin to phonegap-plugin-barcodescanner-android12. Should I change back to the plugin I had when the error occurred and look at the log?

Got it. Yes, use phonegap-plugin-barcodescanner-android12.

Going back to the original message of “You must declare the use of advertising ID in Play Console”: Googling this brings up this StackOverflow thread. It may have some ideas for you.

Thanks George, that was the problem. I had to do a declaration.
I would not have guessed that from the error message.