Error message with obfuscation

I’m trying to create an Android apk file (debug).
With obfuscation set to none, the app runs fine on my device.
With obfuscation set to medium, i get the below error


To test further, i tried it as a web app and with an iPhone and it works fine for both. So the error is only appearing on an Android device.

What can cause this?


Hook up the Android Remote Debugger. Are there any messages on the Console?

I ending up narrowing the error in my app down to sweetalert2.

I was testing on an old Android (version 5.0) which was throwing the error. I couldn’t get Remote Debugger to work for this phone. I then tried using Android 8.1.0 and everything works fine so i’m guessing it’s an Android version issue.

Are there any issues with putting an app on the Android store that is not obfuscated?
I don’t want to put my app on the store then have our opposition download it then see how we do things.


The apk file is nothing more than a zip file renamed.

You can unzip it, then look at the assets in your project, including the source code. If it’s obfuscated, it will slow down whoever is looking at the code, but not stop them.

If you have something critical to do that you don’t want anyone to reverse engineer, you have to put it on your server (and make sure that’s secure!)

Thanks George