Fatal Error! Failed to execute script Appstudio

I rebooted my pc and when I try and start Appstudio, I get the error message.

I’ve just got the same thing. Uninstalled, reinstalled x 3. No change.

I’m sure George (Mr. AppStudio) will like to know your OS (Windows10?) and your version of AppStudio.

Found this in the logs.

2018-02-27 17:29:41,835 - root - ERROR - An exception has occurred!
Traceback (most recent call last):
File “AppStudio.py”, line 414, in
File “site-packages\wx-3.0-msw\wx_core.py”, line 8628, in init
File “site-packages\wx-3.0-msw\wx_core.py”, line 8196, in _BootstrapApp
File “AppStudio.py”, line 225, in OnInit
File “site-packages\verlib.py”, line 86, in init
File “site-packages\verlib.py”, line 95, in _parse
TypeError: expected string or buffer

The solution appears to be the following:

  1. Start RegEdit (Windows Start button, enter regedit)
  2. Find HCU\Software\NSBasic\App Studio.
  3. Delete it.
  4. Restart AppStudio and enter your serial number again.

This was caused by some server maintenance we did yesterday. It should only affect a few users.

Let me know if you have questions!

Important: If you have a Student Term Special License, do NOT do this. You license is good for one installation, so you will not be able to reinstall the software.

That worked. Thank you.

I stopped coding for a while, lost interest etc. Bought myself a 33" screen and a pair of glasses and back to lovin’ it again. Getting old sucks.

i purchased many SN of AppStudio for my computer lab and activate it after that i received Fatal Error message and tried that Regedit method, when i opened the app again the message gone even the serial number, it gives this message (your serial number has been disabled) now i lost my SN what should i do?

Would you send a direct mail with your serial number to support@nsbasic.com?

This same condition just came up in the last hour for my ide installation. Removed the registry items as suggested and all is good.

I got this error after trying to go back from version 8 to an old version 7.

This field doesn’t exist on my pc (windows 10).

I tried also with ccleaner to clean the registry but the error is still blocking the execution.

The solution to this is to do a complete uninstall before installing an old version: