New project with PWA disabled causes 404

I found with a new project, whether saved from another or started fresh: If you set the PWA to disabled true, and then, for the first time for this project, deploy it in any way - like start in desktop browser - causes a 404 for a missing pwa.js file.

If you go back to the project and enable PWA and redeploy, it creates the pwa.js file and it works fine as a pwa (or not if you’re not on a server). But it works as it should.

Then, if you disable PWA and try again, it works - because there is a pwa.js file that is loaded by the browser.

The pwa.js file should not be loaded by the browser in disabled pwa mode.

PS - running a project in non-pwa mode during your initial development cycle of a deploy every 15 seconds speeds up the process of testing significantly. That’s because you made a change and pwa noticed it, and delays the loading of the new page. Disable pwa, and the new pages load on “deploy”.

What’s the exact error message you are seeing?

Your suggestion to set disablePWA to True in Project Properties is a good one. It may not be 15 seconds for everyone, but it’s still faster.

It’s in the console.log: A bad HTTP response code (404) was received when fetching the script.

On the network tab, it shows pwa.js to be downloaded, with status of failed.(instead of 200).

Thanks - I’m seeing the same there here. We’ll fix it.

It’s more of an annoyance - it can be ignored for now.

Fixed in 8.0.3.