Obfuscation - finding an error

When i try to build with PhoneGap and with the obfuscation level set to Low or Medium, i get this message

I’ve been testing the app in Chrome and i get no errors when i run it, and i’ve gone through the app and no errors appear anywhere.

Is there another way to find the issue?


I just tried Hello World, obfuscated and uploaded to PhoneGap. It works fine, so there is more to this issue. Can you isolate it more?

Haven’t found anything yet, but is it possible that a different computer could cause the issue?
I tried the same project on my work PC and obfuscation has no errors. They are both running the latest NSB version.


One of my app users received the below error. I’m not sure if this is related to the obfuscation not working.

Uncaught TypeError:
Cannot read property ‘originalEvent’ of undefined, line 8 column 7109

What can cause this error?


This is probably not related to the obfuscation - look for a regular old bug in your code.

I have seen this error all too often. Every time it was an error in my code, not the obfuscation.

Pity I have to restart AppStudio whenever the message appears, as the IDE still slows to a crawl afterwards…

That seems odd - the error message is in the browser. How could that affect AppStudio?

I was replying to the earlier messages re Warning: Obfuscation failed… Thought you were too, but perhaps not.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.