Phone Gap doesn't seem to be rebuilding

Phone Gap Rebuild done but the QR code still opens up the old app as if no changes were made. It can clearly be seen that it updated 1 hour ago. Is there a solution? Or perhaps, is there a way to delete this app completely then start from scratch?

Have you tried VoltBuilder yet?

It appears Adobe is no longer maintaining PhoneGap.

PhoneGAP did try to build. But there is an exception because of the alias (I renamed to abcd):
Execution failed for task ‘:app:packageRelease’. Failed to read key abcd from store “/var/gimlet/tmp/47090886324420/3854383/…/key_file”: Cannot recover key

I had entered the correct alias at property “Android alias”. abcd appears again within Cordova build.json file. Is this done by AppStudio? Sorry, I do not remember if I could have done this myself some time ago. In any case it had worked about a month ago.

VoltBuilder did it with log:

Reading the keystore from: /certificates/....releasekey.keystore
Running command: /usr/local/Cellar/gradle/6.4/bin/gradle -p /platforms/android wrapper -b /platforms/android/wrapper.gradle
> Task :wrapper


I have not tried VoltBuilder . I will try it and see if it will work with PhoneGap plug-ins

Thank you

A few hours later, a few minutes ago, I repeated a PhoneGap build, downloaded new version .apk and could install as well as run this apk successfully.

All the plugins will work, with the exception of those which have not been updated to keep up with the latest requirements of Cordoba/Android/iOS.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.