PhoneGap Build is down for some people

Last night, PhoneGap Build was updated by Adobe:

The main purpose of the change was to add support for cli-9.0.0, which is required all new apps submitted to the Google Play Store after August 1, 2019. Existing apps have till November 1 to update.

The version of cli is set in Project Properties, in the PhoneGap section, under Version.

Here is what we have found in testing so far:

cli-6.1.0 is no longer supported
cli-6.5.0 is supported, but has errors for some projects
cli-8.0.0 is supported. Some projects work, some do not
cli-9.0.0 has problems

We’re looking at solutions now, and will keep you posted.

We made good progress on this today. We should have hints on using the new release sometime tomorrow.

The blog post on the update to PhoneGap Build is here:
https://blog.appstudio.dev/2019/07/phonegap-build-updates-to-cli-9-0-0/

We were able to update all our samples and get them working in the new release. We will be releasing the updated samples tomorrow.

Build like you always have. There is a bug in PhoneGap Build which causes it to fail intermittently. If you get the message “Error: Android linking failed”, just build again. It will probably work the next time (or the time after that). PhoneGap say they are working on this.

We have just uploaded AppStudio 7.4.2. It has two changes:

  1. PhoneGap: If phoneGapVersion not specified, defaults to cli-9.0.0
  2. PhoneGap Samples: All samples are now compatible with cli-9.0.0

George - before the update (last night) the Make Native App with PhoneGap Build worked fine, now I get this with the new update - tried multiple times.

Error: Source path does not exist: icons/android/ldpi.png

that is not one of my images - something else has changed as well. I was on the version from 2 weeks ago, pretty sure it was the prior.

cli-9.0.0 requires all of your icons and splash screens be set up properly. Some tips:

Great. Just what I needed right now. Thank you.

That worked fine. Thanks
The folder names should be one on a line in extraFiles - just
icons
splash

It seems there are a couple of major issues at the moment with PhoneGap build related to the CLI 9.0.0 rollout.
Firstly there are issues with Installing the app which include the ‘Play Protect’ feature.
The main issue relates to the complete falling down of Ajax support.
My apps generally have a Deploy feature which involves populating tables at the start.
This has completely failed.
I have noted various items in forums including the Adobe PGB support community one where this is flagged.
I realise this is probably an Adobe issue, but it is an app killer for me.
No Ajax, no app…

@Neil_HNF, have you ruled out CSP as a factor? Ajax calls won’t work if your CSP doesn’t list the sites you need to access.

To test this, run on an Android device and hook up the Chrome Remote dev tools. If there is a CSP problem, you will see error message on the Chrome Console tab.

Hi, I spent an hour trying to getting Chrome Remote working but with no success. I can connect the phone and it shows the phone as connected on the PC chrome browser, but that’s as far as I got. I seem to be missing the step where the output of the phone screen is actually sent to the PC…if you can point me to a full step by step I can try that. I have used a generic ’ fully open’ CSP…but it’s possible I missed something there…

I would get rid of the Sencha Touch code in any event. It is no longer supported or maintained.

Does ESLint work on any of your projects? How about the samples?

Ok… making progress.
I’m now debugging the phone app on my PC via USB.
There are some issues with CSP and I’m getting through them. WIll report back on eventual success or otherwise!
Thanks

Ok, I got all the errors out of the app, (and there were a few relating to it! However, there still seems to be an issue with Ajax calls.
I’ve got an alert on error and it’s popping up with : error : Not Found

My CSP is for ref :-

default-src *; img-src ‘self’ data:; connect-src https://my.domain.com ;font-src ‘self’ ; style-src * ‘unsafe-inline’; script-src * ‘unsafe-inline’ ‘unsafe-eval’ ; media-src *;

Given that others (not using NSB have had the issue with Ajax not working with PGB Ajax calls, is it worth assuming the ball is in Adobe’s court?

Thanks,
Neil

Ok, here is the console output highlighting the errors that remain:-

Is this 100% a phonegap build issue?
Thanks,
Neil

The first message “could not find cordova.js” can be ignored.

There are two messages referring to debug2.phonegap.com. Do you have PhoneGap Debugging turned on? Turning that off should get rid of them - but these should not affect your execution.

Are you using Ajax() without a callback function? That has been deprecated, as the message says. You should change your code so a function gets called when the Ajax() function finishes.

Do you have this code in your config.xml?

<plugin name="cordova-plugin-whitelist" source="npm" />
  <allow-navigation href="*" />
  <access origin="*" />

Hi,
Ok, sometimes it’s easy to miss the simple things.
I HAD the whitelist plugin in the config but must have removed it when i was doing trial and error.
I put that back in and NOW…it’s working.
The Ajax is working ok…
However… there are 2 issues outstanding… which are probably Adobe issues:-
There are various prerequisites to doing updates…
(This taken from the Phonegap Build community support Forum (and found to be correct by me))
To install a new apk you must :-
a) bump the version number and build

b) uninstall (exisiting app from phone)

c) install. it should work

d) you cannot install this version number again but must instead bump the version number

During this process the ‘Play Protect’ popup appears every time…

The second item is strange.
On initial loading up of app from install, the Ajax calls don’t work.
However, on closing the app and opening again all is now working. (i tested my whole app and it all works)

While it’s great to have the app working, the user experience will be a bit strange for our customers.

Thanks again for your assistance to date!

Coincidentally, I’m doing some PhoneGap stuff today. I’m seeing the Play Protect messages as well - it’s a new feature from Google.

This is unrelated to PhoneGap.

Thanks. You’re right. I am aware the Play Protect on/off toggle is available.

The Ajax issue has been caused by this :-
https://bugs.chromium.org/p/chromium/issues/detail?id=991107