PhoneGapBarcode plugin not working

I have an app that uses a barcode plugin.It worked on PhoneGapBuild. After my VoltBuild, I am getting an uncaught reference pertaining to that plugin.

So I went back to the sample where I got the plugin from and tried a VoltBuild on that. It also didn’t work.


I even could not open PhoneGapBarcode sample until I found out that this needs double click.
With double click I got an empty design screen. No controls. No code visible.
AppStudio stayed hanging with loading something. I had to kill AppStudio actions.

Interesting, it was there this morning, but now I get exactly what you get - nothing. Perhaps someone is in the middle of a fix and that’s why it isn’t there…

Just tried the PhoneGapBarcode sample here. It worked fine.

  1. Build using VoltBuilder.
  2. Install on device using the QR Code.
  3. Open the app. Give it permission to use the camera to scan.
  4. Scan the QR code from within the app.

What do I need to do to see the problems?

Today AppStudio won’t open any other projects. Locked on this screen. Tried closing, rebooting, etc.

I can pull down the file menu and open sample projects, but when i double click on any, that sample won’t open up, just stays on the locked screen above.

Can you do New Project?

If so, create a new project, save it, then try to open another project. What happens?

Made a new app and saved it.
Did a voltbuild and it worked fine on my phone.

Opened my old app and it comes up.

Then went back to bar code sample. It seems to not be locked up any more so that’s one problem solved but i still can’t do a build.
Bottom left just says ‘add system files’

Then i tried the camera sample and it built fine.

These are the BASIC samples btw

In the About screen, there is a View Log button. Does it show anything?

2020-08-26 13:28:33,828 - root - ERROR - An exception has occurred!
Traceback (most recent call last):
File "", line 1067, in OnStart
File "", line 67, in wrapper
File "", line 2509, in OpenProject
File "", line 411, in AddProject

File "", line 67, in wrapper

File "", line 1059, in Deploy
FileNotFoundError: [Errno 2] No such file or directory: 'includes/scanner.mp3'

Does the time look about right?

How are you deploying?

Also, are you running from the Samples folder directly, or did you save the project to a working directory first?

Must save first, if not, a pop-up comes up saying to save it first.

Yes, the time looks right. If you are referring to this time:


I am deploying from the drop down menu. Or rather, attempting to deploy.

It just seems to be this particular sample. Both Basic sample and Java sample.

And it is this plugin that I need right now.


Hi David, I will be following this closely. I am getting ready to use the same plugin

The plugin is fine - go ahead and use it.

The problem is with the sample. We will fix that.

Thank you!

The fix will be in the next build. In the meantime, there is a simple workaround.

In Project Properties, add includes to extraFiles before saving the sample to your working directory.

Screen Shot 2020-08-29 at 9.47.46 AM