Prelaunch report err -game2n

I didnt supply the csp in my 4 app,so the solution might lies in another thread : ext img…will find out when i reach home tonight…best rdgs,tst

Thank you. Followed the docs. As already said. They do not describe which url is needed to debug an installed app or an apk. Debugging the web app is not useful, because there is no error, no java nullpointerexception

This is the url you type into Chrome to inspect devices:


The app has to be open on the device and connected according to the Google Docs.

On my pc:pending authentication:please accept deugg ing session.
On my phone:waiting for debugger application mathxex (process .tstan.mathxex ) is waiting for the debugger to attach.

Dont know how to continue…

Thank you. The problem comes later. I can view and debug webviews / webpages but not an installed app from apk. If there was a possibility to access an app opened on the device via an URL I would not know how to do this. The arrow points to the url input field I mentioned before.

I think we should stop the investigation by remote debugging. I am spending too much time with a side issue.

The apk app began to crash on the spot only after I had noticed that the Google Play bundle app always crashes immediately and I tried to get at least a working apk again for distribution from my website. I assume that the apk issue becomes more transparent when the bundle app crash issue is solved. Research shows that more and more bundle apps crash immediately. Google offers solely useless or ineffective things for the developer to do. Many people thought the Android System Webview could be the culprit. I even tried the newer Chrome and Webview versions for developers with no success.

Sorry,still offline…

So it looks like it is crashing before the app gets properly launched.

Does the problem happen if you install the apk directly onto the device?

Or does it only happen when you download from the Play Store?

Happened when installed apk directly onto the device. Same when installed from Play Store.
Meanwhile I got again an updated apk which does not crash when installed directly to the device after having removed the line engine name=“android” spec=“10.1.0” from config.xml. I dimly remember that somewhere in the logs was mentioned that there is no 10.1.0.

I think the engine has something to do with this - looking into this now.

My config.sys has in the line after engine:

<uses-sdk android:targetSdkVersion="30" />

because target 30 is needed for the new bundles.
Now the app does not crash. But the BS4 navs do not work any more.
Within other apps with target 29 the BS4 navs still do their job.

I uploaded a new release of PianoCalc to Google Play Store. Crashes as before with:
at (
at (
at (
at (
at (
at$H.handleMessage (
at android.os.Handler.dispatchMessage (
at android.os.Looper.loop (
at (
at java.lang.reflect.Method.invoke (Native Method)
at$ (
at (
Caused by: java.lang.NullPointerException:
at java.util.regex.Matcher.reset (
at java.util.regex.Matcher. (
at java.util.regex.Pattern.matcher (
at org.apache.cordova.ConfigXmlParser.setStartUrl (
at org.apache.cordova.ConfigXmlParser.getLaunchUrl (
at org.apache.cordova.CordovaActivity.loadConfig (
at org.apache.cordova.CordovaActivity.onCreate (
at de.bsommer.pianocalc.MainActivity.onCreate (
at (
at (
at (
at (

We’re working on this now and are able to reproduce the issue.

Thank you for good news and working on this.
BTW: I removed the navs and now use BS4 buttons instead. The apk installed directly onto the Android 11 runs without crash and the navigation to other forms with buttons instead of navs works too.

We may have a solution. It’s an odd one. Add this line to your config.xml:

<content src="index.html" />

Apparently, the updated version of cordova-android now requires this, something which is not documented in the release.

Both of u dianose very well,thanks a lot! Will work on it tonight…

Just in case, because it works anyway.
Apache Cordova docs suggest </content>

<content src="index.html"></content>

In XML land, /> means the same as ></tag>

I try manually upload internal trk with

![Screenshot 2021-09-16 063804|690x388](upload://h0LDLOHo14gGwqNE2SQP4Wqzt4U.jpeg)

<uses-sdk android:targetSdkVersion="30"/>
Removing ...10.1.0
Adding <content src="index.html"/>
Apk run ok,blundle reads "target sdk 29",pls see attached.

Try removing this line:

<uses-sdk android:targetSdkVersion="30"/>

Make sure these lines are present:

<content src="index.html" />
<engine name=“android” spec=“10.1.1”>

That version of the engine automatically uses SDK 30.