Problem with Electron

I tried to run an app using “Run Desktop Using Electron”. The app is very simple–one HTMLView Item and two functions. It runs fine using “start in desktop browser”. However when it opens in the electron desktop, I get an error–“Uncaught Reference Error: isElectron is not defined”–and the console shows both that errorand another reference error, both copied below.

I’m using 8.5.4.0

Any idea what I might be doing wrong?

I’ve copied console messages below.

Uncaught ReferenceError: require is not defined
at index.html:20
appstudioFunctions.js:1949 Error encountered:
Uncaught ReferenceError: isElectron is not defined
Url: file:///C:/Users/smill/Dropbox/NSBasic%20Folders/Gmail/Gconvert.appstudio/electron/nsb/library/appstudioFunctions.js
Line: 2252
Column: 3
appstudioFunctions.js:2252 Uncaught ReferenceError: isElectron is not defined
at Object.NSB.preMain (appstudioFunctions.js:2252)
at index.html:77
VM75 renderer_init.js:113 Electron Security Warning (Insecure Content-Security-Policy) This renderer process has either no Content Security
Policy set or a policy with “unsafe-eval” enabled. This exposes users of
this app to unnecessary security risks.

For more information and help, consult
https://electronjs.org/docs/tutorial/security.
This warning will not show up
once the app is packaged.

Can you try deleting the ‘electron’ folder in your project directory, then running again?

I tried it. It didn’t help. I got exactly the same errors.

Are you on Windows or Mac?

Can you try this test build?

https://www.dropbox.com/t/Rddpf34Hs8FrB6gU

Windows. (Windows 10 Pro).