Tools > Preference: Opening Time

With the last upgrade, I have noticed that it is taking a long time for the Preference Tab to open. On my Windows computer, it’s almost taking 2 minutes. I wonder if something isn’t right in the configuration?
Thanks Rodney

That’s weird. Preferences doesn’t do any processing: it just displays some information which AppStudio already has.

Does a reboot make any difference?

Share your story with the AppStudio Community! Quarantine Stories

I spent about three hours last night trying to get rid of the 2 min opening of the preferences tab. I tried everything. This most interesting part is this:

I uninstalled the program. I checked that the folder in the Program Files (64x) was deleted. I went to the registry and deleted the NSBasic entry. I even deleted the log files.

When I reinstalled the program, in the default Program Files (64x) directory, it won’t run. I even went to the Program Files directory and tried to run program directly (even in Admin mode) but no help. The program won’t even startup… I reinstalled the program a number of times. So now, my annoyance, turned into a REAL problem.

After a little reflection, I decided to reinstall an old version. I think it was version 6, but could have been 7. The program installed in the Program Files (x86) directory being a 32 bit program. Now the program ran, but even this installation had a 2 min delay opening the preference tab.

So, I installed (upgraded) to the version 8 program (latest) and it was installed in the 32 bit directory. But, it did startup and ran. So, I’m not looking a gift-horse in the month and am accepting this situation. Being so thankful the program now runs again, I’ve decided to accept the 2 min opening of the preference tab.

Perhaps if a group of people have the same issue it will be worth tracking down. I am just thankful the program runs…


The only thing you haven’t tried with AppStudio is clearing the registry. Here’s how to do that:

Otherwise, it’s sounding like something weird in Windows.

Share your story with the AppStudio Community! Quarantine Stories

I noticed a lag time going to Preferences some time ago. So I revisited it today and did not have this issue (version 8.0.5). However, some of my apps have a great deal of code scattered in many forms and CodeFiles. If I have many of these forms opened at the same time the SDK is very slow moving from one edit screen to the next so I keep most of them closed when working on a project. This might be the cause of “slow Preferences”. Try closing most of your editing tabs and see what happens.



Thank you for the suggestion. I did try opening a number of different projects and and a couple with one form. But, I never saw a difference.

When I have to open the Preferences tab it gives me a chance to take a break: I have a cup of coffee and sometimes take a short nap… :slightly_smiling_face:

Thanks again, Rodney