Turn off debugging

Can you tell me how to turn off debuggable? Play Store requires that it be taken out. This is their description for how to take it out, unfortunately, I don’t know where these are located.

Turn off logging and debugging

Make sure you deactivate logging and disable the debugging option before you build your application for release. You can deactivate logging by removing calls to Log methods in your source files. You can disable debugging by removing the android:debuggable attribute from the <application> tag in your manifest file, or by setting the android:debuggable attribute to false in your manifest file. Also, remove any log files or static test files that were created in your project

Are you using PhoneGap Build? If so, this could be the setting:

I am using Phone Gap. Mine looks like this . . .

The screen shot is from http://build.phonegap.com.

You’ll need to sign on there with your account to change this setting.

If you click “Settings” you will see this:

Thanks. I tried several ways and keep hitting road blocks.
I went to my PhoneGap account and tried to upload the apk that I had zipped.
I get ‘ERROR index.html not found’. Since the apk was made by PhoneGap, I am surprised PhoneGap is having trouble finding this. Any idea how to fix this new problem?
Related: Is there a way to use the ‘PhoneGap Build ID’ or ‘Download Link’ to get it into PhoneGap account? (the one that is given to me from the PhoneGap pop up I get from NSB as shown in the previous screen shot)?

Have you checked your config.xml?

    <config-file platform="android" parent="/manifest" mode="merge">
      <application android:debuggable="true" />

If this is set in the config.xml, no matter what settings you change via the GUI, this setting will override everything else because this is part of the config.xml and the config.xml gets passed to the compiler and the compiler listens to the config.xml first. The GUI settings only have precedence when there is no setting in the config,xml.

No mention of debuggable in my config.xml. Can i put it in there and make debuggable=“false”?
if so, would i copy and paste what you have above and change the true to false? (I am not familiar with how the config.xml works, i just know that it is there and i can change it.)

Yes. Try that and report back.

however, if i just plunk it down in the code like this, it will compile…
I can try to see if the Play Store will accept it now.

Negative. That does not turn off debugging as far as Play Store is concerned.

Upload failed

You uploaded a debuggable APK or Android App Bundle. For security reasons you need to disable debugging before it can be published in Google Play.

The apk is the output from PhoneGap - it won’t work as input when uploaded.

Are you able to sign into your PhoneGap account (on http://build.phonegap.com) and look at the settings of your app? If so, post the screen shot here. (It should look like @bsommer’s)

That is the original problem, I can’t find my app on my Phone Gap account. I thought it would be there since I got a PhoneGap Build ID when I used ‘Make Native app with PhoneGap’.
So i tried to upload it here, which I think you are referring to using output as input?

In the tools / preferences of AppStudio, you’ll see a tab PhoneGap. You’ll need to insert your API code from the PhoneGap Build web site into that field. Otherwise, you are “uploading” to a “demo” account. A link to the instructions is just below the API code field.

OMGsh. That was so easy. Thank you!

Hmm. I still get this note that I am uploading an app with debugging…

even though i have not enabled debugging… thoughts?

David, double-check that your app is signed correctly. Phonegap Build will default to creating a “Debug” version of your app if it’s not signed or signed correctly. In your Phonegap account, make certain you have the correct signing key selected prior to letting AppStudio upload the build.

Then when downloading it from Phonegap, the filename should have “release” in the name (i.e.

I think you should not use UPLOAD. Leader already said that AppStudio does build the apk which is ready and can be downloaded via AppStudio or PhoneGap. I do not really understand what is going wrong. But I suspect you need to have a key which is unlocked by certificate and keystore passwords you provided. After input of these passwords you can click Rebuild and after some time download the apk by clicking apk button. Building the keys for iOS and Android is another rather complicated procedure. But you can find help with AppStudio or just research. Having done this once you can use these keys for each of your apps. This is my “daily” and successful procedure.

My next baby step is hitting a road block. I followed the NSB video tutorial on how to generate a key.
All went well to this point . . .

Microsoft Windows [Version 10.0.18362.778]
© 2019 Microsoft Corporation. All rights reserved.

C:\Users\David> cd C:\Program Files (x86)\Java\jre1.8.0_251

C:\Program Files (x86)\Java\jre1.8.0_251>keytool -genkey -v -keystore PedCalc.keystore -alias PedCalc -keyalg RSA -keysize 2048 -validity 10000
‘keytool’ is not recognized as an internal or external command,
operable program or batch file.

There seems to be some disagreement on fixes I am finding. They have to do with the way JAVA_HOME is set up in Environmental Settings. Some say it needs to be ‘…\bin’
Some say both jre and jdk need to be there.
What is the definitive solution?