Unable to select controls within containers in Design mode

I’m using AppStudio on a couple of laptops running on Windows 10 but have an issue with the design mode. If I have a container control (or CSSGrid, GridRow etc) and I add another control then I can only select the container control - even if I have not added as a child control. I have also tested using the sample projects and get the same result. The problem is that once I’ve added controls I can no longer select them if I am using containers.

Have you tried right clicking in the container?


Yes, it selects the item in the container - but as soon as I right-click on the selected item, it selects the container again

Can you give a step by step so I can understand exactly what you are doing? Include screenshots if that will help.

Using the CSSGrid sample project…
Step 1: I select CSSGrid1 control in the Design screen
Step 2: I right click and select from the context menu - CSSGridItem1
Step 3: I attempt to right click the selected item (CSSGridItem1) so that I can add control or add child or move - but it now highlights/selects the CSSGrid1 control again

Got it - I’ll see what we can do.