Voltbuilder iOS Build Failed

When I try to build for iOS Debug I get this error:

TypeError [ERR_INVALID_ARG_TYPE]: The “url” argument must be of type string. Received undefined

Android Debug: Builds ok

No easy answer here. The complete message is

File not found: TypeError [ERR_INVALID_ARG_TYPE]: The “url” argument must be of type string. Received undefined
This could be caused by a problem with a plugin.

First step will be to figure out which plugin it is. Best way to do this is remove a plugin and try running again. Problem gone away? That was it.

I’d try cordova-plugin-x-socialsharing first.

Once you know which one, hit the docs for that plugin.

Ok’ I’ll check the plugins.

This is from the error log:

mkdir platforms/ios/www/toolbox/bs4/dist/open-iconic/fonts
copy www/toolbox/bs4/dist/open-iconic/fonts/open-iconic.woff platforms/ios/www/toolbox/bs4/dist/open-iconic/fonts/open-iconic.woff (new file)
The “url” argument must be of type string. Received undefined
TypeError [ERR_INVALID_ARG_TYPE]: The “url” argument must be of type string. Received undefined
at new NodeError (node:internal/errors:372:5)
at validateString (node:internal/validators:120:11)
at Url.parse (node:url:168:3)
at Object.urlParse [as parse] (node:url:155:13)
at parseWhitelistUrlForATS (/platforms/ios/cordova/lib/prepare.js:1001:22)
at /platforms/ios/cordova/lib/prepare.js:960:25
at Array.reduce ()
at processAccessAndAllowNavigationEntries (/platforms/ios/cordova/lib/prepare.js:951:10)
at writeATSEntries (/platforms/ios/cordova/lib/prepare.js:1079:18)
at updateProject (/platforms/ios/cordova/lib/prepare.js:208:17)

I removed all of my plugins and I still get the same error.

Double check your zip file - you still have these:

    <plugin name="cordova-plugin-splashscreen" source="npm" />
    <plugin name="cordova-launch-review" source="npm" />
    <plugin name="cordova-plugin-inappbrowser" />
    <plugin name="cordova-plugin-x-socialsharing" source="npm" />
    <plugin name="cordova-pdf-generator" />
    <plugin name="cordova-plugin-printer" />

Yes, the last build I tried I added them back in again.
I had previously commented them out with <!-- --> . I’ll try it again but this time I will completely remove them rather than just comment them out.

Same error still.

I just tried it again > I closed AppStudio, re-launched AppStudio and get the same error.

You missed one:

<plugin name="cordova-plugin-whitelist" />

Since that will be looking for a URL, the message makes sense.

Nope, wasn’t that, still same error.

Do I still need this:

 <platform name="ios" >
 <preference name="WKWebViewOnly" value="true" />
 <feature name="CDVWKWebViewEngine">
 <param name="ios-package" value="CDVWKWebViewEngine" />
 <preference name="CordovaWebViewEngine" value="CDVWKWebViewEngine" />

I just checked and noticed my ios certs expired, hopefully that’s it, I’ll let you know shortly.

It wasn’t the iOS certs.

As I said, the problem is the cordova-plugin-whitelist.

If you don’t need the plugin, do not include it.

Here are the docs:
cordova-plugin-whitelist - npm.

Are you sure? because I removed it earlier (along with all the other plugins) but still got the same error.

I can you send the app to try?

Ok, commenting this lot out seems to have removed that error, I have another error now but its unrelated.

<!-- <allow-navigation href="*" /> -->
<!-- <allow-intent href="*" /> -->
<!-- <access origin="*" />  -->
<!--  <access allow="*" />  -->```