VoltBuilder - iOS

I’m getting intermittent Bad Gateway 502 errors, VoltBuilder is busy and very, very occasionally a successful build for ios -debug since yesterday. And now also starting to see VoltBuilder is busy on the android build. Any known issues?

No issues that we know of. I just ran a test job: it worked fine. The server certainly isn’t busy today.

I notice your builds are failing with errors in the compile. Looks like problems configuring OneSignal.

OK. I don’t seem to be seeing any logs. Is there any way to see logs when these errors occur!

You appear to have a toxic job. It hangs in the middle of the build with no error. We’re looking at it now. There’s no way a job should be allowed to hang the server!

In the meantime, other jobs should run fine.

Thanks. It’s very odd as sometimes I’d see 502 error, sometimes VoltBuilder is busy and even a successful build on the odd occasion - all with the same settings. Have tried a very simple project and also removing plugins one by one.

The problem is in this plugin:

<plugin name="cordova-plugin-googlemaps" source="npm">

One of its components takes 25 minutes to install:

npm install https://github.com/mapsplugin/cordova-plugin-googlemaps-sdk

We’re changing VoltBuilder to better handle is, but it looks like that plugin is broken.

BTW, by the time it finishes, it has added 175 megs to your app.

That’s the same plugin I was having problems with. I had to drop back to version 2.6.x

We’re thinking of adding it to the red_list. Is it useful enough that we should leave it on the green_list somehow?

The Googlemaps plugin? Definitely useful. I’ll take a look at the 2.7.0 release - GitHub (https://github.com/mapsplugin/cordova-plugin-googlemaps/issues) suggesting it is 2.7.1 that is the cause of this problem

Which version of 2.6.x did you have success with? I’ve been able to successfuly build using Voltbuilder for ios - debug with v2.6.1 of the googlemaps plugin. However, that wouldnt work for android - debug. However, v2.7.0 of the googlemaps plugin worked for android… but not ios…!

We’ve added a timeout to VoltBuilder. If any step takes longer than 5 minutes, the job gets killed.

This will affect some versions of the GoogleMaps plugin. It downloads 200 megs from GitHub, which was never intended to be a CDN. Furthermore, it downloads the complete repo, including tons of stuff it has no intention of using. A job yesterday using the plugin took 54 minutes, blocking other users from getting stuff done.

A key recommendation for anyone using this plug in. Specify the version and steer clear of latest version (2.7.1). I’ve found 2.7.0 works on Android and 2.6.2 for iOS.

As an update for anyone wanting to use both OneSignal and GoogleMaps cordova plugins in a project, I’ve tested successfully now on OneSignal v2.10.1 with GoogleMaps v2.7.0 with both Android and iOS