Voltbuilder onesignal-cordova-plugin plugin error

Hi George

My app use onesignal-cordova-plugin to send push to users.
Since i compile in Volt i did not realize push stop works…
Anaysing the Onsesignal code I concluded there someting wrong in VoltBuider

    window.plugins.OneSignal.getIds(initPushSuccess)   - this fufunction initPushSuccess is not fired

I did the same test in phonegap and wors fine…

Can you include the error message? Without that, it’s hard to help.

VoltBuilder uses the latest Cordova tooling. Many plugins and usages will need to be updated: users were held back by PhoneGap not being up to date. If you run into issues, that’s one of the first things to consider.

No errors in Volt Builder
Just the function is not fired…
I compiled on phonegap and back the same source …
Phonegap works, not volt … Really really weird
I even make a small app for you to test there …

Vou testar no android, estava testando no iOS sorry my portuguese…
I was testing in ios… i will try in android… and android wors… Really really weird

the request for send notification is showed, but still not working in ios, andoid is ok…
i was thinking if it is not something about polices…

As I said, there have been changes to Cordova since PhoneGap. What worked there may not work any more - it’s not VoltBuilder’s fault.

If it makes the ipa file OK, but doesn’t work at runtime, you need to use a Mac to see what error messages are appearing on the console. Once you see those, you will probably know what needs to be fixed.

How can i see the problem in mac in ipa?

Make sure the One Signal code is is called when device is ready otherwise build will fail.

i m sure… i did put print in all calls

George, can i send you a little project with only Onesignal problem?

We’re not experts in Cordova Plugins.

Feedback… Problem solved…
i was using

<gap:plugin name="onesignal-cordova-plugin" spec="~2.4.0" source="npm" /> 
but the lastest versions: 2.11.0 and 2.11.1 not works...
set to
<gap:plugin name="onesignal-cordova-plugin" spec="2.10.1" source="npm" />
and wors fine!


The underlying problem has also been fixed.