Voltbuilder Output not working in relation to file system

I spent a few months perfecting a video recording/transcoding/storing/uploading system on a simple app and it finally all worked perfectly in July and August.
I last built it on September 2nd on PGB and that version of the app works perfectly.
I’ve been test building my apps on Voltbuilder and in general all is good(especially when the team there add Plugins to the Voltbuilder library).
However, my video sample app is now not working purely due to the fact that it’s telling me the generated video files
e.g. file:///storage/emulated/0/DCIM/Camera/VID_20200917_094812.mp4

do not exist!

my code (which is working with the last PGB build ) updated the above file path to

file://DCIM/Camera/VID_20200917_094812.mp4 and then ran : -


function deletefilenow(path){

window.requestFileSystem(LocalFileSystem.PERSISTENT, 0, function(fileSystem){
fileSystem.root.getFile(path, { create: false }, fileExistsdel, fileDoesNotExist);

function fileExistsdel(fileEntry){

alert("Cannot be Removed!");
alert("Doesn't exist!");

function fileDoesNotExist(){
alert("Doesn't exist!");

End JavaScript

Any ideas what’s changed between PGB and and Voltbuilder?


Tip: If you’re pasting code, html or config files, surround it by triple back ticks (```) and it will be fomatted properly.

Hook up the Chrome Remote Debugger and look in the Console for error messages.

I’ll bet the problem is with CORS settings. This is a new requirement by Chrome - it was not in place in the PhoneGap days (but the same problem issue have happened in PG apps)

This isn’t running in Chrome as such it’s a compiled apk file.
I can try and run it with the debugger with the phone attached…but I’ve never had huge success with that.
Will come back to you.

Ok… I’ve got a problem with Remote Debugging in Chrome
I can’t get my samsung devices to be recognised.
The tutorial / guide doesn’t seem to have enough detail for me to figure it out
is there a debugger for debugging the debugger?

(and yes I have gone into developer mode ., enabled USB debugging etc etc)

Can CORS be an issue within an android device looking at files in its own storage?

Yes, there can be a CORS issue within an android device looking at files in its own storage.

Ok, so this is interesting…
I just installed the new voltbuilder version of the app onto a tablet with Chrome79 on it and it worked fine.

The PGB version of the app from 2nd September works fine on a device with Chrome85.
The voltbuilder app on a device with Chrome85 has the ‘file finding’ issue.

So…assuming this is a CORS issue…is there a way to resolve this with a config setting or CSP entry?