Wasm database error (and other issues)

  1. Have a look in the log. There is probably a message about the splash screen.

  2. Cordova’s documentation for AndroidInsecureFileModeEnabled is here. Hope it helps!

  3. Can you give a bit more information? How can I reproduce this?

Dear George

Q1, where can i get log if run as native app?

Please find attach sample project for Q3


Project1.appstudio.zip (7.94 KB)

  1. After you build using VoltBuilder, it gives you the option of downloading the log.

  2. This is correct. While classic BASIC using parenthesis to reference array elements, AppStudio BASIC uses square brackets: a[1]


Dear George

Here the log file. Please help me to identify the splash screen problem

Voltbuilder.2024-06-03 10-46-38.log (15.6 KB)

Open the file in an editor and search for the word ‘splash’. Here’s the message that you are getting:

The "AndroidWindowSplashScreenAnimatedIcon" value does not exist. 
Cordova's default will be used.

It’s not finding your file.

Dear George

I did have this preference in config.xml

splash.png is also in Images folder

What possible problem?


Try www/Images/splash.png

Dear all

after update to, my app freeze at splach screen (both web app and native app). I have attached screen shot with console error.
Please advice

config.log (2.5 KB)
my os is win 10 pro


Do you have SQLite (WASM) checked in the Libraries window?


Dear Ghenne

yes, SQLiteWASM is checked. I am able to find all .js file in web server bin folder.
Any other problems?


Are you accessing SQLite right away when the app is started? It may be that the loading of the SQLite modules is not complete by the time you first try to use it.

You should not try to access SQLite until Main() is called.


I do not have main(), but i have “sqlopendatabase” statement in first form onshow() function. (tested by run as desktop browser, the seq for app to run is main() then first form onshow())
After many tried, Here are the outcomes

Firstly native app is working after uncheck sqlite(wasm)

Secondly, same sqllite wasm error (https://app.oetapp.my/beta2/OETms/nsb/library/jswasm/sqlite3.wasm net::ERR_ABORTED 404 (Not Found)) when run as web server. PS: sqlite3.wasm if existing in web server

Lastly, sqllite(wasm) is loaded successfully when run as desktop browser. However i cannot debug the app since ajax is not function as local browser

Any ideas for app to run as web app?


The first form onshow() function is too soon. You need to wait unitl the Main() function to call SqlOpenDatabase.

SQLite WASM takes a bit longer to load than the native SQLite did - but you were still lucky it worked before.