Windows exe installs but won't launch

When trying to create an exe file for my app, I get the following message
"Create process failed: code 14001
The application has failed to start because its side by side configuration is incorrect. See the application event log for more detail. I don’t know where that log is.
The exe is created and even goes through the install process but fails when launch is attempted. What is this telling me and how do I get the exe to work? Is there something wrong with the app’s code? It starts fine in the desktop browser and deploys ok to volt.

  1. Which version of AppStudio are you using?

  2. Does the same thing happen in a sample such as Hello World?

I get the same thing with one of the samples. After the dos screen does its thing, a pop up says the exe was created but when I close that box another pop up says Windows cannot find the file. I set it to deploy to a local folder and the exe is in that folder.

I just tried HelloWorld here and it worked fine, so there’s something about your system.

Create a new folder named HelloWorld and save the HelloWorld sample in that folder.
Then, do “Make Windows Executable”.

If that does not work, the log files will be in your new HelloWorld folder.

I did as suggested but with same results. After running make windows exe, the same pop up says the file was created but then says it can’t find the exe in the hello world folder. There is another hello world folder created within the first one and it does contain helloworld.exe but then it results in the same message after installing as described earlier. There is only a make.innotsetup log but i don’t think that is what I am looking for. The failed code 14001 also has a message that c:\programfiles(x86)\hello world\wrapper.exe was unable to be executed. Wrapper.exe is not in the hello world folder where the exe is but I copied it there from another place on my computer. It did not make any difference. Do you believe re-installing appstudio.exe will help? I will experiment with various scenarios to try to find a solution but will also try whatever you think might solve this issue.

My laptop doesn’t seem to have the same problem with making a windows executable. The hello world stuff works with it but I would much rather be able to use my desktop computer. Laptop runs Windows 10 but desktop windows 7.

The solution for now might be to build using Windows 10 only.

We do not have any Windows 7 machines in the lab currently, so I cannot promise a quick fix.

I will make the exe files in my win 10 laptop and transfer them to the Win 7 desktop. Since my Volt subscription ends tomorrow, I need something I can send to those users who will wonder what happened when their app goes away. Thanks anyway for your efforts.