AppStudio 8.5 Beta

AppStudio 8.5 Beta 4 is ready for testing. We’d like to get some people to try it before release.

The biggest change is that we have updated the UI library used by AppStudio (wx). It has a lot of little fixes and cosmetic improvements.

There is a long list of improvements and fixes:

Here’s is what is new:

  1. BS4: Updated to 4.6
  2. BS4: Bootswatch themes updated to 4.6
  3. BS4: Input password now has option to toggle plain text on or off.
  4. BS4: Navs - fix .clear() and .addItem() functions
  5. BS4: Slider - Add .hide() and .show() functions
  6. Code Window: Improve function list to catch more JavaScript function formats.
  7. Code Window: Improved function name find.
  8. IDE: MacOS: control keys for copy and paste work in dialog windows.
  9. Demo: Do not allow Cordova Build.
  10. Deploy: Allow wasm files to be deployed.
  11. Deploy: Some redundant code eliminated - may be quicker
  12. Design Screen: Change “Add Component” to “Add Control”.
  13. Electron: Spaces are not allowed in Title
  14. Electron: Updated to 9.4.0. (electron-builder and npm also updated)
  15. IDE: Copyright is now 2021
  16. IDE: MacOS: control keys for copy and paste work in dialog windows.
  17. IDE: wxPython updated to 4.1.1. Uses wxWidgets 3.1. Tons of fixes and minor improvements.
  18. Installer: Renew signing certificate
  19. Navigo: Updated to 8.4.3. Used by BrowserArrows (see sample)
  20. Project Properties: Remove androidDname - replaced by VoltSigner
  21. Project Properties: Signing filenames default to VoltSigner’s values.
  22. Run Menu: Add “Get Signing Certificate with VoltSigner” .
  23. Run Menu: Change “Volt” to “Volt Server”.
  24. Samples: Change PhoneGap references to VoltBuilder.
  25. Samples: Volt Services is now called VoltServer.
  26. Samples: SQLSample1 updated.
  27. Samples: Some samples would not open due to a PWA_manifest problem.
  28. SQLite: SqlOpenDatabase now takes only 1 argument.
  29. SQLite: When running as a native app, the Cordova library is used instead of the browser’s.
  30. VoltBuilder: Default key names to be same as VoltSigner defaults.
  31. VoltBuilder: Remove reference to xmlns:gap in default config.xml
  32. VoltBuilder/Cordova: Main() is now called on deviceready event.
  33. VoltSigner: added to Run menu.

Breaking change : When running as a native app, the Cordova library is used instead of the browser’s. That means the database data will be saved in the file system and not in the browser’s sandbox. Please check where your app is saving the data: you may have to consider a migration strategy if you are affected. Please contact if you need help. The need for this changed comes from Safari changing support for WebSQL. This does NOT affect web apps.



As usual, let us know if you spot anything unusual!

I’m getting this error Uncaught ReferenceError: Form1 is not defined at Object.NSB.preMain (appstudioFunctions.js:2268) at (index):2402

I dont have a Form1, works ok on the previous version of AppStudio.

Would you be wiling to share your project so we can have a look?

If so, please send it to me directly.

Hi, its the same project i sent you previously if you still have it?

Sorry - we don’t keep these around any longer than is required for the specific problem we are looking at.

Does this help? My first form is named Home, (not form1).

  if (typeof(isElectron) === 'undefined'
    && NSB.EULAtext != ""
    && localStorage.Project1_EULA != 'true') {
	} else {
  	if (typeof(Form1.onshow)=='function') Form1.onshow();

The above is from the Chrome console error, found in nsb/library/appstudioFunctions.js

Will we still have to do a full deploy before doing a refresh deploy?

No change there.

@Pro_Certs - the bug you found has been fixed (thanks). It’s, available now at the same URL.

It seams to be fixed, thank you.

I tried to move from 76 mb downloaded on 11/27/20 at 12:00 noon EST to the latest beta. It installs fine, but will not launch. Windows 10, 64 bit. All I did was install 8.5 beta over the I then reinstalled over the bad 8.5 and now the works. Other than I get the following error when I open AppStudio:


What can I send to help get 8.5 installed?

Does it make any difference if you do a complete uninstall?

Are you on Windows or MacOS?

In the instructions for the total uninstall, it is not clear what registry key to delete:

Remove the registry entry:

  1. Start RegEdit (Windows Start button, enter regedit)
  2. Find HCU\Software\NSBasic\App Studio.
  3. Delete it.

Are we deleting the NSBasic key or just the App Studio key? And obviously not the HCU or Software keys. I deleted the former (NSBasic key). I was going to suggest spelling out HCU, but if you’re in regedit, then you better know WTF you are doing and what HCU is.

Other than that, it installed and I was able to bring up my main project. I ran it under start in desktop and it is acting oddly. EG, it works in and not in 8.5 beta. I will hunt this down, as it looks like a logic error - hmm.

The 8.5 beta problem I believe is the same as AppStudio 8.4.2 won't run. I think it exemplifies the reasons for never releasing two versions with the same version number, especially when the difference between them was a major installer change.

I forgot to reset my port number in the Advanced section. All appears to be working fine.

I did find that for the move from Bootstrap 4.4 to 4.6 that is in 8.5, that the Bootswatch themes were updated, but only to 4.5, not 4.6. 4.6 appears to be available from the publisher on their github. The publisher also says it is very important to keep the versions in sync.

Thanks - we’ll update the themes right away.

New Error:

Error response Error code: 404 
Message: File not found.
Error code explanation: HTTPStatus.NOT_FOUND - Nothing matches the given URI

To reproduce:

  1. Tap ‘Start in browser’
    Once the app has opened in the browser
  2. Change form from Form 1 to Form2
  3. Tap ‘Start in browser’ (again)
    = 404 not found

@Pro_Certs: are you using one of the samples for this? Or your own app?

@GaryGorsline - we’ve just uploaded Beta 6. It has the updated Bootswatch themes. Thanks for spotting this!

My own app.

I’ll try and reproduce it with a blank project.

I have sent you a test project which reproduces the 404 error.