AppStudio 9.0.5 released!

We’re pleased to announce that 9.0.5 has been released. There are improvements to ChatGPT and SQLite support - check out the new SQLDump() command!

Support for Android 12 splashscreens has also been added.

Here is the list of fixes and enhancements:

  1. ChatGPT: Now uses gpt-3.5-turbo-0125. Can handle more data in and out.
  2. Samples: SQLSample1 has a new Lookup feature.
  3. Samples: SQLSample1 now saves to localStorage and clears database properly.
  4. Splashscreens: Support for Android 12 splashscreens added.
  5. Splashscreens: New splash background property.
  6. SQLite: Additional required files are now deployed.
  7. SQLite: Data saved to localStorage by default
  8. SQLite: Error reporting improved.
  9. SQLite: Headers for OPFS support added.
  10. SQLite: New SQLDump() command for the console.
  11. SQLite: Main() is not called until SQLite WASM finished loading
  12. SQLite: Warning appears if no SQLite library is installed when trying to open.
  13. SQLite: SQLite WASM no longer needs to be selected if using Cordova plugins
  14. SQLite WASM: Updated to 3.46

You can download the new release from within AppStudio or from our site .

If you have any questions about the new release, ask on our forum or

1 Like


The download links to AppStudio ?




Would you give it another try?

Fine now.




Running on a MAC using Safari as the target browser (I have also tried other browsers), I have encountered issues that do not occur in Specifically, I am using “Start in a Desktop Browser” run-mode to run a Leaflet map app. No issues in but in the latest release multiple browser errors occur, starting with several ‘Source Map loading errors’ (‘file not found’ or ‘load failed’) that do not happen in the html run from the previous version. Whether these are related or not the end result is that tiles from fail to load. Changing the CSP directives or making them completely open doesn’t help. Anyway, it still works fine in the run from the previous version.
Not sure if is related, but I also note that a new, always empty, ‘extraheaders.html’ has been generated in the properties folder of the project despite there being entries for these in the project.

  1. Does your project have extraheaders?

  2. Try installing again to see if the problem goes away:


  1. Yes. My project has the following extra headers:
<link rel="stylesheet" href="" integrity="sha256-p4NxAoJBhIIN+hmNHrzRCf9tD/miZyoHS5obTRR9BMY=" crossorigin=""/>
<!-- Make sure you put this AFTER Leaflet's CSS -->
<script src="" integrity="sha256-20nQCchB9co0qIjJZRGuk2/Z9VM+kNiyxNV1lvTlZBo=" crossorigin="">
  1. Yes. The problem goes away if using


P.S. Here is a simple project that demonstrates the problem: (24.0 KB)

Thank you - we’ll look at this right away.

I’m able to load and run it, but I get a lot of error messages - mostly cross origin.

Could you send a screenshot of your console so I can see what errors you are getting?

This is what I see when I run from my server:

Thanks George.

To be clear on what you mean by “when I run from my server”, are you talking about the localhost server after launching the app in test mode via the AppStudio “Start in Desktop Browser” run button? This is where my problem occurs. Deploying the app to VoltServer for example, is fine.

Here is the screenshot after the “Start in Desktop Browser” launch:

Again to be clear, if this is just an effect of the new version imposing more constraining but legitimate html rules, than that’s OK. I’m just a bit slow working out what to include in the project to forgo this.

The major change between run creation in this versus the previous version seems to be the appstudioFunctions.js contents. In the end I can continue to work in for development if that’s the only way to cater for my hacking style of development (you may have guessed that my IT career didn’t include a lot of programming! :slight_smile: ).


@jim - I’m able to reproduce this here, so we’re working on this.

In the meantime, if you deploy to a server (or Deploy to Local Folder), the problem should go away.

Having some issues with the new version (on Android device)
SQLExport no longer working (which is a fairly major one for my ability to debug)
(Was / is working on previous version)

I’m also having some strange issues INSERTing image data into tables and then recalling for AJAX Posting.
(i’m aware this should be kept to a minimum - but it was working fine on the previous version.)

Will continue testing.

@Neil_HNF - On the device, are you using the Cordova plugin?

I’ve ticked the SQLite WASM tick box - is that what you mean?

Are you running as a native app (using VoltBuilder) or directly on the device?

Voltbuilder native app.

@Neil_HNF - Try turning off SQLite WASM in the toolbox. Does that make a difference?

Hi George,
Sorry - had multiple deadlines to hit so I had to leave this. Will be back on it shortly.

So I unticked
SQLite (WASM) and instead used the plugin cordova-sqlite-evcore-extbuild-free .

Now, it seems to work well. No issues with photos populating tables.
No problem with SQLExport either.
Seems to be a minor problem with creating one of the tables… but I need to investigate that. (i have 27 tables in this project)

So… in general… it seems this ‘works’ on the device a bit better than the SQLite WASM library… (for now!)